update check always returns newest/highest version, independent if the add-on is compatible or not to the appVersion (updatecheck, update.rdf, addon, incompatible)

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
--
major
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Details

(URL)

Mossop spotted this:

AMO's update check always returns the newest/highest version, independent if the add-on is compatible or not to the appVersion

https://versioncheck.addons.mozilla.org/update/VersionCheck.php?reqVersion=2&id={9c51bd27-6ed8-4000-a2bf-36cb95c0c947}&version=10.0.3&maxAppVersion=3.2a1pre&status=userEnabled&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=1.5.0.4&appOS=Darwin&appABI=x86-gcc3&locale=en-US&currentAppVersion=1.5.0.4

Returns v10.1.0 which isn't compatible instead of v10.0.3 which is

Keywords:
(updatecheck, update.rdf, addon, incompatible)
This was done intentionally a while back because of problems with SQL sorting version numbers. It will return the latest version compatible with the client application, regardless of client version number.
wontfix from comment 1
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
Dave Dash worked on converting version numbers to integer values, has this become product-ready so it could be used for this?
Duplicate of this bug: 601836
Duplicate of this bug: 601836

Comment 6

7 years ago
Bug 611551 was fixed so I decided to give this a test. I installed Flagfox 3.3.20 in Firefox 3.0, then tried to update it. Just a little while ago, no update was available because current Flagfox 4.1.0 is not compatible with Firefox 3.0. This time it let me update to Flagfox 4.0.14, the last available version compatible with Firefox 3.0. The testcase in comment 0 is still valid and it too now produces the correct result: it now returns version 10.0.3 instead of the current version 11.0.1.

WONTFIX -> FIXED!
Depends on: 611551
Resolution: WONTFIX → FIXED

Comment 7

7 years ago
(Actually, now I'm not sure if it was bug 611551 or another, as I'm not sure that is live on production yet. Please correct me if it was fixed in another bug. Regardless, this bug is fixed now.)
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.