If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Initial and relaunch times degraded by 10x on Win98

VERIFIED MOVED

Status

Derivatives
Netscape 6
P3
normal
VERIFIED MOVED
17 years ago
6 years ago

People

(Reporter: chriss, Assigned: John Bandhauer)

Tracking

({perf})

Details

(Reporter)

Description

17 years ago
I'm running a win98 PII/300Mhz/160MB RAM laptop.
I've installed PR1 and PR2 (Aug 4 M17 Build) in separate directories.

Steps to reproduce 
1. reboot computer
2. launch Netscape 6 PR1 and then quit
3. launch Netscape 6 M17 and then quit
4. relaunch PR1 and measure time for Nav window to appear
5. relaunch M17 and measure time for Nav window to appear

I get 8 sec for PR1 and 80 sec for PR2; therefore start time performance has 
degraded by 10x on relaunch. 

Initial start times are also bad. I will reboot and take another set of 
measurements.
(Reporter)

Comment 1

17 years ago
I measured the first time relaunch (after OS reboot). Here are the times I got:

PR1 17 sec
PR2 90 sec

So initial launch takes approx 5x longer and relaunch 10x longer.
Another data point is that I ran the same test on Win2000 desktop with what I 
believe is a slower processor than my laptop and M17 start performance was much 
much faster. So this appears to be a Win98 problem.

Adding [perf] keyword.
Keywords: perf

Comment 2

17 years ago
This is commercial specific...moving to Derivatives Product for a move to 
Bugscape.
Assignee: asa → leger
Component: Browser-General → Netscape 6
Product: Browser → Derivatives
QA Contact: doronr → leger
Version: other → unspecified

Comment 3

17 years ago
reassign this to paw for proper person this should go to.
Assignee: leger → paw
(Reporter)

Comment 4

17 years ago
I deleted mozver.dat file and did a reinstall.
The launch time problem went away. Unfortunately I didn't save my copy of 
mozver.dat.

Comment 5

17 years ago
Warren can you take a look at this or assign it to someone who can.  Thanks.

Also changing QA Contact
Assignee: paw → warren
QA Contact: leger → paw

Comment 6

17 years ago
Maybe jband has some cycles to look at this.
Assignee: warren → jband
(Assignee)

Comment 7

17 years ago
Maybe Dan can offer a clue on what might be in mozver.dat that could cause such 
a load time difference. Also, doesn't this mozver.dat wrinkle bring into doubt 
the assertion that this was a Win98 specififc problem rather than a problem 
caused by an old mozver.dat on that machine (which happened to be running 
Win98)?
(Assignee)

Comment 8

17 years ago
dveditz told me that he can't think of any rationale by which any version of 
mozver.dat could cause such a thing. 

I'll try to reproduce this and see what happens.
Status: NEW → ASSIGNED

Comment 9

17 years ago
Bug moved to http://bugscape.netscape.com/.

If the move succeeded, paw@netscape.com will recieve a mail
containing the number of the new bug in the other database.
If all went well,  please mark this bug verified, and paste
in a link to the new bug. Otherwise, reopen this bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → MOVED

Comment 10

17 years ago
The move did not work.  Shiva is check to find out why.  Adding shiva to the cc
list.
(Assignee)

Comment 11

17 years ago
This bug is assigned to me. Why are you moving it?

Comment 12

17 years ago
Per Jan leger's comments in the bug.  This bug is commericial only, so it was to
be moved to bugscape.  Jan no longer works at netscape, so I inherited this task
of moving commerical only bugs to bugscape. Your ownership is not affected the
bug just lives in a different bug database.

Comment 13

17 years ago
Asa or Paul, could you verify that this was, indeed, MOVED?  Thanks.

Comment 14

17 years ago
I can't find it in bugscape. I tried to move a while ago but it failed, so I
have left the bug here.

Comment 15

17 years ago
Bug moved to http://bugscape.netscape.com/.

If the move succeeded, asa@mozilla.org will recieve a mail
containing the number of the new bug in the other database.
If all went well,  please mark this bug verified, and paste
in a link to the new bug. Otherwise, reopen this bug.
Status: RESOLVED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: MOVED → MOVED

Comment 16

17 years ago
verified.  This is now bugscape http://bugscape.netscape.com//show_bug.cgi?id=2677
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.