Closed Bug 476334 Opened 13 years ago Closed 13 years ago

Add NSIS to about:license

Categories

(Firefox :: General, defect, P2)

3.5 Branch
x86
Windows Vista
defect

Tracking

()

RESOLVED DUPLICATE of bug 476817

People

(Reporter: robert.strong.bugs, Assigned: gerv)

References

Details

This was suppose to have been done a long time ago in Bug 331660 which Bug 344662 got duped to and I just noticed it hasn't been done... I REALLY don't want these people to be overlooked for the work they have done on NSIS which is what we use to create the installer used by the vast majority of Firefox users. One new name added to the list is Jim Park... he made the Unicode version of NSIS which we are using for Firefox 3.1 and above.

Ximon Eighteen
Justin Frankel
Dave Laundon
Jim Park
Robert Rainwater
Amir Szekely
Joost Verburg
Flags: blocking-firefox3.1?
Connor: do we normally uplift credits like this, or just include "the NSIS team" or something?
Flags: blocking-firefox3.1? → blocking-firefox3.1+
Priority: -- → P2
What actually happened, FWIW, was that these guys got added for Fx2, but ended up in the "who are these guys" list and no one gave info on new contributions for the Fx3 credits round, so they got dropped in that revision.

It's a little tricky to figure out how to credit members of other projects.  NSIS is certainly not the only project that falls into this category, of course, so I should really get a crisper policy together.  I also should redo the credits stuff so it's a lot easier to handle these issues, since I'd like to link to other projects/groups directly, rather than try to uplift everyone from every project we embed.  Especially given the version-ness of this stuff.
Assignee: nobody → mconnor
I've sent an email to Gerv asking if NSIS could be added to about license... NSIS doesn't have a main contributor which is the way that is usually formatted. I'll post back in this bug after I get a reply.
Whiteboard: [needs patch]
Assignee: mconnor → gerv
Summary: Add NSIS devs to credits → Add NSIS to about:license
Whiteboard: [needs patch] → [waiting on info from NSIS]
btw: Gerv also filed bug 476817 to see if this can be added to about:license... I thought they would just be added to the credits but it makes more sense for them to be in about:license.
Does it make more sense or do we want to do both?
It makes a lot more sense to do the same as we've done for all of the other projects whose code we've used.
ditto to what mconnor said
Depends on: 476817
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476817
note: bug 476817 has been pushed to mozilla-central and mozilla-1.9.1
Whiteboard: [waiting on info from NSIS]
Flags: blocking-firefox3.1+
You need to log in before you can comment on or make changes to this bug.