Location Bar Autocompletion too slow (blocks keyboard input)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: jjh_nospam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

When I enter text into the location bar, Firefox starts searching the browsing history and bookmarks so it can autocomplete the text I entered and offer suggestions in a list underneath the location bar. 

The problem is:
While firefox is searching, the location bar's textfield becomes irresponsive: I can keep on typing, but no letters appear until Firefox has finished it's search and displays suggestions in a list underneath the location bar.

A possible solution would be:
Don't block the textfield's thread while searching for autocompletions and list entries.

Reproducible: Always

Steps to Reproduce:
1. have a lot of bookmarks in your bookmarks library (mine are without tags but kept in many folders) and a long browsing history
2. start firefox on mac osx
3. right after the firefox window has appeared, klick into the location bar and enter some text (any text will do, for example start typing 'dogs school')
Actual Results:  
having typed a few letters, firefox will have begun it's autocompletion search. any further letters you type won't appear in the location bar's textbox until firefox has completed it's search and displays the list underneath the location bar.

Expected Results:  
firefox should not block the textfield's user interface while searching for autocompletions.

Comment 1

10 years ago
try safe mode (http://support.mozilla.com/kb/Safe+Mode) please, some addon is known to cause slowdowns.

Comment 2

10 years ago
This bug is just one of many general awesomebar performance complaints, isn't it?  It's not specific at all.  Marco, should we mark it as a dupe of bug 478097?

Comment 3

10 years ago
mh, no, that's a special optimization done for 3.1 (that was lagging a bit more than 3.0), does not apply as a generic optimization bug to 3.0.x branch.

Updated

10 years ago
Duplicate of this bug: 487221

Comment 5

9 years ago
 Johannes,  Brandon, 
do you still see this when started in safe mode using version 3.6?
 http://support.mozilla.com/kb/Safe+Mode
Whiteboard: [closeme 2010-02-25]
(Reporter)

Comment 6

9 years ago
I just updated to firefox 3.6 and now it is better: Now when I type, the letters appear at once and don't wait for the autocompletion search results. I would suggest to mark the issue as fixed.
thank you for feedback.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Depends on: 455555
Resolution: --- → WORKSFORME

Updated

9 years ago
Whiteboard: [closeme 2010-02-25]

Comment 8

9 years ago
The address bar seems to be working flawlessly now!  Thanks a ton!

Updated

9 years ago
Duplicate of this bug: 544526
You need to log in before you can comment on or make changes to this bug.