extreme toolkit.zoomManager.zoomValues

VERIFIED DUPLICATE of bug 474309

Status

()

Firefox
Disability Access
VERIFIED DUPLICATE of bug 474309
10 years ago
10 years ago

People

(Reporter: David, Unassigned)

Tracking

3.0 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Extreme use of toolkit.zoomManager.zoomValues breaks zoom functionality.
The following works fine:
0.0260840533045888,0.0313008639655066,0.0375610367586079,0.0450732441103295,0.0540878929323954,0.0649054715188745,0.0778865658226494,0.0934638789871793,0.112156654784615,0.134587985741538,0.161505582889846,0.193806699467815,0.232568039361378,0.279081647233653,0.334897976680384,0.401877572016461,0.482253086419753,0.578703703703704,0.694444444444444,0.833333333333333,1,1.2,1.44,1.728,2.0736,2.48832,2.985984,3.5831808,4.29981696,5.159780352,6.1917364224,7.43008370688,8.916100448256
The following does not:
0.0260840533045888,0.0313008639655066,0.0375610367586079,0.0450732441103295,0.0540878929323954,0.0649054715188745,0.0778865658226494,0.0934638789871793,0.112156654784615,0.134587985741538,0.161505582889846,0.193806699467815,0.232568039361378,0.279081647233653,0.334897976680384,0.401877572016461,0.482253086419753,0.578703703703704,0.694444444444444,0.833333333333333,1,1.2,1.44,1.728,2.0736,2.48832,2.985984,3.5831808,4.29981696,5.159780352,6.1917364224,7.43008370688,8.916100448256,10.6993205379072,12.8391846454886,15.4070215745864,18.4884258895036,22.1861110674044,26.6233332808852,31.9479999370623,38.3375999244747



Reproducible: Always

Steps to Reproduce:
1. Change toolkit.zoomManager.zoomValues to 0.0260840533045888,0.0313008639655066,0.0375610367586079,0.0450732441103295,0.0540878929323954,0.0649054715188745,0.0778865658226494,0.0934638789871793,0.112156654784615,0.134587985741538,0.161505582889846,0.193806699467815,0.232568039361378,0.279081647233653,0.334897976680384,0.401877572016461,0.482253086419753,0.578703703703704,0.694444444444444,0.833333333333333,1,1.2,1.44,1.728,2.0736,2.48832,2.985984,3.5831808,4.29981696,5.159780352,6.1917364224,7.43008370688,8.916100448256,10.6993205379072
2. Zoom in and out
Actual Results:  
The zoom would skip increments and skip back to different increments.

Expected Results:  
It should zoom in increasing order of the increments listed.
There was a recent fix pushed for this exact problem, can you test the latest nightly build at ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/ .

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474309

Updated

10 years ago
Status: RESOLVED → VERIFIED
Version: unspecified → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.