JavaScript exception in UpdateJunkButton when opening an .eml message file

VERIFIED FIXED in Thunderbird 3.0b2

Status

MailNews Core
Backend
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: IU, Assigned: Magnus Melin)

Tracking

({regression})

Trunk
Thunderbird 3.0b2
regression
Bug Flags:
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

1.44 KB, application/x-zip-compressed
Details
941 bytes, patch
Joey Minta
: review+
Details | Diff | Splinter Review
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090201 Lightning/1.0pre

Opening a .eml message file results in various JavaScript exceptions.

If Shredder is default email client and the .eml file is double-clicked (in Windows Explorer) to open, the following two exceptions occur:

Error: [Exception... "'Failure' when calling method: [nsICommandLineHandler::handle]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "<unknown>"  data: no]
------
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMsgDBView.hdrForFirstSelectedMessage]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger/content/mailWindowOverlay.js :: UpdateJunkButton :: line 1823"  data: no]


On the other hand, if the message is opened via File --> Open Saved Message..., only the second of the two exceptions occur.

These are regressions as follows:

1. First exception (NS_ERROR_FAILURE): Regressed starting: version 3.0a1pre (2008041103)

2. Second exception (NS_ERROR_INVALID_POINTER): Regressed starting: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080922031046 Shredder/3.0b1pre


Reproducible: Always

Steps to Reproduce:
1. Save the attached email somewhere on your filesystem
2. Open Error Console and scroll to bottom
3. Double-click sample.eml and note the exceptions in Error Console
4. Click File --> Open Saved Message..., browse to and open sample.eml.  Note the exception.




A report (Bug 471648) exists, but that seems more concerned with other aspects and does not contain much information.  I'll leave it up to more knowledgeable people to determine, after careful review, which direction to dupe to.
(Reporter)

Updated

9 years ago
Component: General → Database
Flags: wanted-thunderbird3?
Keywords: regression
Product: Thunderbird → MailNews Core
Version: unspecified → Trunk
(Reporter)

Comment 1

9 years ago
Created attachment 360058 [details]
Sample email file
(Reporter)

Comment 2

9 years ago
Created attachment 360059 [details]
Sample email file
(Reporter)

Updated

9 years ago
Attachment #360058 - Attachment is obsolete: true
QA Contact: general → database

Comment 3

9 years ago
not a database bug - by definition, there's no db for a .eml file :-)
Component: Database → Backend
QA Contact: database → backend
(Assignee)

Comment 4

9 years ago
Created attachment 361152 [details] [diff] [review]
proposed fix
Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #361152 - Flags: review?(jminta)
(Assignee)

Comment 5

9 years ago
One issue per bug, this only deals with the update UpdateJunkButton exception.
Flags: wanted-thunderbird3? → wanted-thunderbird3+
OS: Windows XP → All
Hardware: x86 → All
Target Milestone: --- → Thunderbird 3.0b2
(Assignee)

Updated

9 years ago
Attachment #361152 - Flags: review?(jminta)
(Assignee)

Comment 6

9 years ago
Comment on attachment 361152 [details] [diff] [review]
proposed fix

Gah.
(Assignee)

Comment 7

9 years ago
Created attachment 361154 [details] [diff] [review]
proposed fix, v2
Attachment #361152 - Attachment is obsolete: true
Attachment #361154 - Flags: review?(jminta)

Updated

9 years ago
Attachment #361154 - Flags: review?(jminta) → review+
(Assignee)

Comment 8

9 years ago
changeset:   1892:76a345246ea5
http://hg.mozilla.org/comm-central/rev/76a345246ea5

->FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Summary: Javascript exceptions when opening a .eml message file → JavaScript exception in UpdateJunkButton when opening an .eml message file
(Reporter)

Comment 9

9 years ago
Filed follow-on: Bug 477719
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.