js-ctypes doesn't build on source tree < 1.9.1

RESOLVED FIXED

Status

()

Core
js-ctypes
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: snotling, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5
Build Identifier: 

Due to nsIXPCScriptable::postCreatePrototype() recent(?) addition, js-ctypes doesn't build on source tree < 1.9.1.

../../../../../../toolkit/components/js-ctypes/src/xpcom/nsNativeMethod.cpp:526: error: no ‘nsresult nsNativeMethod::PostCreatePrototype(JSContext*, JSObject*)’ member function declared in class ‘nsNativeMethod’

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Confirmed
Component: js-ctypes → js-ctypes
Product: Other Applications → Core

Comment 2

8 years ago
Fixed by landing in mozilla-central.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.