simplify browser.xul styles

RESOLVED FIXED in fennec1.0b1

Status

Fennec Graveyard
General
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Gavin, Assigned: Gavin)

Tracking

Trunk
fennec1.0b1

Details

Attachments

(1 attachment, 2 obsolete attachments)

We can use a single selector instead of adding the style inline on each element for the -moz-stack-sizing stuff. Also adds a license header.
Created attachment 360147 [details] [diff] [review]
patch
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #360147 - Flags: review?(mark.finkle)
Comment on attachment 360147 [details] [diff] [review]
patch

The flex is there so that the stack is sized to the window width by default, but it's not strictly necessary since we'll resize the stack anyways.
Attachment #360147 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mobile-browser/rev/731f6fc9c130
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Fennec A3
Backed out, since it might have caused a Ts regression:
http://graphs.mozilla.org/#show=2774468,2774466,2774464
https://hg.mozilla.org/mobile-browser/rev/7fc04c681e32
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Gavin, are you going to try to land this again or has it bit rotted beyond usefulness?
Still needs landing, just need to figure out which part caused a regression. Just the CSS styling changes alone are probably safe?
Created attachment 382142 [details] [diff] [review]
only CSS

If this causes a Ts regression I will eat my hat.
Attachment #360147 - Attachment is obsolete: true
Created attachment 382144 [details] [diff] [review]
only CSS (fixed)
Attachment #382142 - Attachment is obsolete: true
Attachment #382144 - Flags: review?(mark.finkle)
Attachment #382144 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mobile-browser/rev/ace0dda38376
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.