Closed Bug 476545 Opened 11 years ago Closed 11 years ago

Assertion followed by crash on first run after upgrading from 3.0.5

Categories

(Firefox :: General, defect, major)

x86
Windows Vista
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 476292

People

(Reporter: jfkthame, Unassigned)

Details

Attachments

(1 file)

With a fresh Minefield build from mozilla-central trunk, I get an assertion the first time the application is started:

###!!! ASSERTION: nsTHashtable was not initialized properly.: 'mTable.entrySize', file c:\mozilla-central\obj-ff\dist\include\xpcom\nsTHashtable.h, line 163

After clicking Continue in the assertion dialog box, the application then crashes.

This only occurs on the first run when "upgrading" from Firefox 3.0.x; re-launching the new Minefield application runs successfully without this assertion and without crashing.

To reproduce: Run the released version of Firefox 3.0.5. (Assuming you have previously been running 3.1 prerelease versions, this will report that you have "upgraded" to the latest release.)

Exit Firefox, then launch Minefield.

Results: on the first run, Minefield asserts (as above) and crashes. Relaunch Minefield and the crash is gone.

I have seen this behavior on both XP and Vista machines.
This looks like a dupe of bug 476292, since it's on initializing a hashtable and happens on migration.
Looks like the crash occurs when Minefield is initializing the History. As this only happens on first run after previously using 3.0.x, I guess it's updating the old profile or history in some way, and that's leading to the problem?
Aha.... yes, probably a dupe of that. Sorry, didn't find it when I tried searching for the assertion in bugzilla.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476292
You need to log in before you can comment on or make changes to this bug.