crash in mscvrt when page done loading

VERIFIED WORKSFORME

Status

SeaMonkey
General
P3
blocker
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: mozilla, Assigned: asa)

Tracking

({crash})

Trunk
x86
Windows 98
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-], URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win98; U)
BuildID:    2000080404

when starting the build with homepage set to http://slashdot.org
the browser crashes in mscvrt with follwing error
MOZILLA caused an invalid page fault in
module MSVCRT.DLL at 017f:780011ce.
Registers:
EAX=0243bb0b CS=017f EIP=780011ce EFLGS=00010202
EBX=02690828 SS=0187 ESP=0068f87c EBP=0068f884
ECX=0014d2c2 DS=0187 ESI=01f07000 FS=1187
EDX=00000003 ES=0187 EDI=028b1e68 GS=0000
Bytes at CS:EIP:
f3 a5 ff 24 95 a8 12 00 78 8b c7 ba 03 00 00 00 
Stack dump:
02690810 01dd51a4 0068f8b8 6063e28b 0278000c 01dd51a4 00666967 0068f914 02692590 
0241fce0 01dd5137 000001bf 0068f8d0 0110004f 0241fbf0 0068f918 
msvcrt version is 6.10.8637.0

Reproducible: Always
Steps to Reproduce:
1.startup mozilla


Actual Results:  crash					

Expected Results:  browser window
(Reporter)

Comment 1

18 years ago
some extra info
the crash occurs when the page is 92% loaded so it does display the page for a 
while
Summary: crash in mscvrt at startup → crash in mscvrt at startup
(Reporter)

Comment 2

18 years ago
changing the summary to a beter one
the crash actualy when the page is done loading
pressing stop during the page load does not crash the browser
Summary: crash in mscvrt at startup → crash in mscvrt when page done loading
(Reporter)

Updated

18 years ago
Keywords: nsbeta2

Comment 3

18 years ago
Loading just fine for 2000080404 commercial branch for Win95.  Asa...if you see 
on Win98...let me know.
Whiteboard: [nsbeta2-]
(Reporter)

Comment 4

18 years ago
crash also occurs on win2000
with and without sp1
mscvrt version : 6.1.8637.0
talkback's are being sent (when the server isn't busy again)
i think the dll is installed with the napster beta 7 but that's the only thing 
added to the system before that mozilla was running fine
sorry to bother you guys so much but i miss my mozilla
(Reporter)

Comment 5

18 years ago
the problem is cache related i removed the cache directories and now everything 
works fine
(Assignee)

Comment 6

18 years ago
antoher corrupted profile bug. Reporter, were you using an old profile with that
install of Mozilla?  Resolving WFM per reporters comment.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

18 years ago
yes this was using an old install,
i was thinking that this was related to the install of napsterb7 but never 
thought about cleaning the profile until yesterday

Comment 8

18 years ago
Adding crash keyword for fix and/or verification escalation
Keywords: crash

Comment 9

18 years ago
verified WFM, 081508 win95
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.