WCAP provider seems broken with Shredder 3.0preb2 + Lightning 1.0pre 02/02 builds



Provider: WCAP
9 years ago
9 years ago


(Reporter: Laurent Bauvens, Unassigned)




(2 attachments)



9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv: Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090202 Lightning/1.0pre Shredder/3.0b2pre

Creation of a new WCAP calendar is possible but it will be unusable.
No authentication is asking and reload-remote-calendars has no effect
After restarting shredder, the new WCAP calendar will have disappeared from the calendar pane.

Reproducible: Always

Steps to Reproduce:
1. Create a new WCAP calendar 
2. The new calendar appears in the calendar pane. It is unchecked and has a yellow attention sign on the right side. 
3. Place the mouse cursor on the calendar name and a information message appears which says "The calendar XX is momentarily not available". But in few cases the calendar doesn't appears at all.
3. Check the calendar does not do anything. No authentication is asked.
4. A view on calendar properties permits to view that calendar is in read only mode.
5. Restart Shredder. The new WCAP calendar has disappeared.
Actual Results:  
Once the WCAP calendar is created, Lightning never asks for authentication. 
The calendar is unchecked and in a read-only mode. 
The calendar disappears when Shredder is restarted.

Expected Results:  
Authentication is asked and datas are correctly retrieved from the server.
The new calendar remains in the calendar pane after a Shredder restart.

Comment 1

9 years ago
Created attachment 360314 [details]
Lightning log file


9 years ago
Flags: blocking-calendar1.0?
should block in case it's confirmed
Keywords: qawanted
Summary: WCAP calendaring seems broken with shredder 3.0pre b2+Lightning 1.0pre 02/02 builds → WCAP provider seems broken with Shredder 3.0preb2 + Lightning 1.0pre 02/02 builds

Comment 3

9 years ago
I've tested the WCAP provider with the last nightly builds (2009-04-15) of TB30B3 and LG10pre. The result is the same than in my first description.
Please note type and version of the server. Please check Tools > Error Console during retest and copy and paste related error messages to this bug report.

Comment 6

9 years ago
Created attachment 373307 [details]
Lightning 1.0pre WCAP log file 2009-04-17

This log file traces a connexion attempt on sd-calendar.staroffice.de with user JDOE.

Comment 7

9 years ago
The log file I have join in attachment comes from a connexion attempt with "http://sd-calendar.staroffice.de/?calid=JDOE". One can see inside this logfile some "uri: unknown, not logged in, calId=JDOE".
"uri: unknown" seems to be very abnormal. I think uri should be "http://sd-calendar.staroffice...."
"not logged in" is normal because Lightning doesn't ask for authentication. A possible consequence of "uri: unknown" ?

FYI, our Sun Calendar Server is a 6.2+ and the problem met is exactly the same.
WFM; no problem using "http://sd-calendar.staroffice.de/". Please try without a specific calid, you're asked for it anyway.

Comment 9

9 years ago
OK, it works well without a specific CALID. 

That means the bug should be renamed for example in "A parameter isn't supported in WCAP calendar URI in LG10pre".
That's true, the calid parameter is not supported any longer. It's derived out of the user id used on first login (i.e. the time when the user's subscriptions are installed). The user id can be prefilled, e.g. http://jdoe@sd-calendar.
Sorry, I won't denote to support it again and removed it form the wiki page.
Last Resolved: 9 years ago
Resolution: --- → WONTFIX


9 years ago
Flags: blocking-calendar1.0?
Keywords: qawanted

Comment 11

9 years ago
Perhaps it makes sense to forbid validation of the URI dialog if this latter contains a '?' ?
This may avoid the strange result which made me file this bug.
You need to log in before you can comment on or make changes to this bug.