Please redirect bug###.b.m.o to the bug summary and not to b.m.o homepage

RESOLVED FIXED

Status

()

RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: tomer, Assigned: justdave)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
I've seen that since one of the last bugzilla upgrades, each bug has its own subdomain when watching attachments. Do you mind to redirect the subdomain itself to the bug view when accessing it? It looks silly to me that when I access https://bug476495.bugzilla.mozilla.org I gets redirected back to https://bugzilla.mozilla.org.

Steps to reproduce: 
a. Watch an attachment from any bug in Mozilla Bugzilla server. For example, attachment 360361 [details] from bug 476495 (https://bug476495.bugzilla.mozilla.org/attachment.cgi?id=360361).
b. Try to be smarter and remove the attachment part from the browser location bar, in order to go back to the bug summary. 

Expected result:
User should be redirected to https://bugzilla.mozilla.org/show_bug.cgi?id=476495 or see the bug details in its own subdomain.
I concur. This was the behavior I expected, as well.
Duplicate of this bug: 480358
Assignee: nobody → justdave
Done.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
For the record (in case anyone following along wants to accomplish the same on some other Bugzilla install) the magic incantation in httpd.conf is:

   # Let the bug subdomains redirect to the bug instead of to the home page
   RewriteCond %{SERVER_NAME} ^bug(\d+)\.
   RewriteRule ^/$ https://bugzilla.mozilla.org/show_bug.cgi?id=%1 [R=302,L]
Thanks, Dave!
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.