Inconsistent back button behavior

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: ddriscoll, Unassigned)

Tracking

3.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.19) Gecko/20081216 Fedora/2.0.0.19-1.fc8 Firefox/2.0.0.19
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.19) Gecko/20081216 Fedora/2.0.0.19-1.fc8 Firefox/2.0.0.19

A web page uses javascript to vary the src attribute of
an image tag by reading in graphics files from an array.This is done
automatically using the setInterval method or manually via user
control. When the array is exhausted, javascript uses the
window.location function to jump to a new page.
If manual, back button returns to the previous page in its initial state.
If automatic, back button returns to previous page in its final state.

If javascript tries to load a non-existent picture file just before
calling window.location, in automatic mode the back button returns to
previous page in initial state.

Reproducible: Always

Steps to Reproduce:
1.load page
2.use javascript to alter content (img.src="newpicture")
3.use setInterval (or setTimeout) or not.
4.use window.location to new page
5.backbutton result depends on whether setInterval was used. 
Actual Results:  
if setInterval running backbutton shows page with newpicture
if setInterval not running backbutton shows page before newpicture loaded
if setInterval running but non-existent file called just before jump to new window backbutton shows page before newpicture loaded

Expected Results:  
same behavior whether or not timer has been set

I have a tar file with pages that show described behavior
(Reporter)

Comment 1

10 years ago
Created attachment 360406 [details]
contains test.php end.php & graphics files in graphics and pictures dirs

load test.php, Auto is default will auto step through to end.php, click "m" at top of page for manual click "next" arrow at bottom to step through to end page. Backpage behavior is same but if comment out line 186 (loads dummy page) backpage is different for auto and manual modes.

Comment 2

10 years ago
Firefox 2 is not supported anymore. I suggest you upgrade to Firefox 3.0.6 or later, then try in a new profile to see this behavior.
Version: unspecified → 2.0 Branch

Comment 3

10 years ago
INVALID unless it happens in 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

10 years ago
happens in 3.0.5 on linux and macosx

Comment 5

10 years ago
OK, thanks for trying on that. Have you tried in a new profile? http://support.mozilla.com/kb/profile
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Version: 2.0 Branch → 3.0 Branch
(Reporter)

Comment 6

10 years ago
I get the same behavior on 2 linux boxes one running ff 3.0.6 and one running 3.0.5, mac osX runing 3.0.5 and winxp running 2.0.0.18 which profile do you want to change?
(Reporter)

Comment 7

10 years ago
changed profile on linux fedor 8 ff 3.0.6 no change-back button from single step mode goes back to page in initial state, back button in auto mode goes back to page in final state.

Comment 8

10 years ago
Could this be a dupe of bug 466586?
This is a mass search for Firefox General bugs filed against version 3.0 that are UNCO and have not been changed for 200 days.

Reporter, please update to Firefox 3.6.10 or alter. Firefox 3.0 is no longer supported and is no longer receiving updates. After you update, please create a fresh profile, http://support.mozilla.com/kb/managing+profiles, and test to see if your bug still exists. If you still the bug, then please post a comment with the version you tested against, and the problem. If the issue is no longer there, please set the RESOLUTION to  RESOLVED, WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.