Closed Bug 476768 Opened 11 years ago Closed 11 years ago

Specific sites crash firefox on ALL linux distros

Categories

(Core :: Graphics, defect, critical)

All
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 424333

People

(Reporter: onatawahtaw, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.5) Gecko/2008121623 Ubuntu/8.10 (intrepid) Firefox/3.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.5) Gecko/2008121623 Ubuntu/8.10 (intrepid) Firefox/3.0.5

Sites such as http://www.strictlyamish.com and http://www.rempel-furniture.com/index.php?id=1 crash firefox immediately. The page apparently only contains html, minor javascript, and some onpage css.

Reproducible: Always

Steps to Reproduce:
1.Open firefox on a linux system (Ubuntu, Debian, CentOS, etc.)
2. Navigate to the website: http://www.strictlyamish.com
Actual Results:  
Firefox instantly crashes

Expected Results:  
Firefox should display page
Not a crash; it's an X error. Terminal output:
The program 'firefox-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 49034 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Cause is their background image:
http://www.rempel-furniture.com/typo3conf/ext/defaultstatic_tmpl/crcph/files/bg.jpg
which is a 1x60000 pixel image

Does not occur with recent Firefox 3.1b3pre and instead has redraw problems.

Pretty sure this is a dupe of bug 424333, but the title says GIF there so I'm not sure if it's the exact same issue or just similar.
Severity: normal → critical
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
Whiteboard: dupeme?
Yeah, same issue; the format doesn't matter, just the size is relevant.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424333
Whiteboard: dupeme?
You need to log in before you can comment on or make changes to this bug.