Closed Bug 476800 Opened 11 years ago Closed 11 years ago

Kill variadic macro warnings in js/src

Categories

(Core :: JavaScript Engine, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: mrbkap, Assigned: benjamin)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch Patch (obsolete) — Splinter Review
I'm tired of the millions of variadic macro warnings we get. Here's a patch.
Attachment #360447 - Flags: review?(jim)
Attachment #360447 - Flags: review?(jim) → review+
-Wno-variadic-macros is valid for gcc 4 but not gcc 3 -- it causes gcc to throw an error during compilation instead.

I think gcc 3 users are pretty much stuck with the errors unless we use #pragma GCC System_header (sp?) -- which is horrendous. 
 
configure.in near line 782 shows a way to test GCC major version number -- can we get that sort of test and only -Wno-variadic-macros for major version -ge 4 added to the patch before landing?
Comment on attachment 360447 [details] [diff] [review]
Patch

Get a real compiler! ;-) I'll refresh the patch to take old GCCs into account.
Attachment #360447 - Attachment is obsolete: true
Attachment #360447 - Flags: review+
Heh, jorendorff filed a dup of this. We can use configure tests to determine supported flags, there are examples in /configure.in
Duplicate of this bug: 476164
Assignee: mrbkap → benjamin
Attachment #360535 - Flags: review?(ted.mielczarek)
Attachment #360535 - Flags: review?(ted.mielczarek) → review+
(In reply to comment #0)
> I'm tired of the millions of variadic macro warnings we get.
Why not get rid of the variadic macros ;-)
http://hg.mozilla.org/mozilla-central/rev/2a10c8f1fa11
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
(In reply to comment #6)
> Why not get rid of the variadic macros ;-)

Patches welcome, but I don't have time right now to disentangle that maze of macros.
Flags: in-testsuite-
Flags: in-litmus-
You need to log in before you can comment on or make changes to this bug.