Closed Bug 476823 Opened 11 years ago Closed 11 years ago

nsFileSystemDataSource doesn't implement nsISupports

Categories

(Core Graveyard :: RDF, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: neil, Assigned: neil)

References

Details

(Keywords: fixed1.9.1, regression, verified1.9.0.9)

Attachments

(1 file)

... which makes it impossible to use from JS, for instance.
Flags: blocking1.9.1?
Flags: blocking1.9.0.8?
Attached patch Proposed patchSplinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #360479 - Flags: superreview?(benjamin)
Attachment #360479 - Flags: review?(sayrer)
Attachment #360479 - Flags: superreview?(benjamin)
Attachment #360479 - Flags: superreview+
Attachment #360479 - Flags: review?(sayrer)
Attachment #360479 - Flags: review+
Flags: wanted1.9.1+
Flags: blocking1.9.1?
Flags: blocking1.9.1-
Wouldn't block, but we'll take the patch.  Approving in a sec.
Flags: wanted1.9.1+
Flags: blocking1.9.1?
Flags: blocking1.9.1-
Ditto comment 2 for the 1.9.0 branch.
Flags: blocking1.9.0.8? → wanted1.9.0.x+
(In reply to comment #4)
> Ditto comment 2 for the 1.9.0 branch.

So wanted-1.9.0.x twice? :-p
Pushed changeset 3bf7e3fae8bf to mozilla-central.

Pushed changeset b746930b1c17 to releases/mozilla-1.9.1
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: fixed1.9.1
Resolution: --- → FIXED
Attachment #360479 - Flags: approval1.9.0.7?
Comment on attachment 360479 [details] [diff] [review]
Proposed patch

Although this is brain-dead simple, we are already frozen for 1.9.0.7 and don't want to restart the QA clock. We'll definitely take in 1.9.0.8 once the tree reopens.
Attachment #360479 - Flags: approval1.9.0.7? → approval1.9.0.8?
Comment on attachment 360479 [details] [diff] [review]
Proposed patch

Approved for 1.9.0.8, a=dveditz for release-drivers
Attachment #360479 - Flags: approval1.9.0.8? → approval1.9.0.8+
Fix checked in to CVS.
Keywords: fixed1.9.0.8
Verified for 1.9.0.8 by looking at source since it is a simple change.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.