Spreadfirefox current dependence on OG CTA

RESOLVED FIXED

Status

Websites Graveyard
spreadfirefox.com
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: Paul Booker, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
Hello,

I would like to put forward the proposal to move away from the 'OG CTA' module
and instead towards a solution that possibly incorporates the 'content access' module.

Currently we use the 'OG CTA' module to allocate content types as follows:

Group Default:
Image, Discussion Topic, Poll, Event, Document, Page

Specific Groups:
For a small collection of groups 247 Marketing Inc, Community @ SFX ,..
we use the group default types minus the 'Poll' content type.  

Site Wide:
Webform, Image, blog, Discussion Topic, Poll, Event, Document, Feed, Feed items
(NO Page & Story content types are allowed)


Instead of restricting content types dependent upon group context i would like to propose that instead we work out a solution along the lines of content type restriction based on user roles. Here is my simple suggestion:

Authenticated users:
Image, Discussion Topic, Poll, Event, Document, Page
Administrator users:
Webform, feed, feed items
Blog users:
Blog

We can then make any fine adjustments with the help of the 'content access' module. 
http://drupal.org/project/content_access

Some important facts
We have migrated the OG CTA module to D6 but currently there looks to be 25 / 50% performance hit with our current RC1
The 'content access' module has a strong community around it in the order of a 1000's users compared to OG CTA which is in the order of 10's of users

Paul
(Reporter)

Comment 1

9 years ago
Just letting everyone now that there are problems with this module on a production server of mine with multiple users simultaneously accessing the site.

I'll work on resolving this problem this next week just to keep our options open but if we can we should remove our sites dependency on this module.  

Paul
I agree, this module has been giving us a headache lately.  Paul, what does this module provide and how do you recommend we go about replacing it?

Thanks
(Reporter)

Comment 3

9 years ago
This module allows a group manager to control what node types subscribers are allowed to post into the group and also allows the site administrator to dictate what node types are available for a group and whether they are required.

This module worries me a little as it throws out all node access privileges on with each page request and then recalulates them dependent on node type & group context.  

I would recommend turning it off you should find that you can live without this module.

Paul
Thanks Paul.  I agree, this module looks pretty broken and we should move away from using it.  However, I don't think we can just turn it off.

The content access module sounds like a possible solution for user access to content types.  I'll have to look into that one more.  Maybe you can set up a demo of how it works?

The OG CTA module does more than just user perms.  It provides the per-project sidebar block, so we'll need to discuss how to go about replacing that.

Also, I think we should double check that we're not overlooking any other functionalities that OG CTA provides which we need to replace.
(Reporter)

Comment 5

9 years ago
(In reply to comment #4)
> Thanks Paul.  I agree, this module looks pretty broken and we should move away
> from using it.  However, I don't think we can just turn it off.

Can you advise how the OG CTA module is broken from your perspective ?

> 
> The content access module sounds like a possible solution for user access to
> content types.  I'll have to look into that one more.  Maybe you can set up a
> demo of how it works?

I can set this up but i would recommend just trying to see if you can have stage working with the OG CTA module disabled before installing other modules.


> 
> The OG CTA module does more than just user perms.  It provides the per-project
> sidebar block, so we'll need to discuss how to go about replacing that.

You can revert to the original sidebar block that comes with OG

> 
> Also, I think we should double check that we're not overlooking any other
> functionalities that OG CTA provides which we need to replace.

Feel free to double check.
Assignee: mary → nobody
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 6

8 years ago
OG CTA performance issues are now resolved on D6 so we can continue using this module.

Best, Paul
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
This module is still enabled in production.  Could you explain why you "resolved fixed" this bug, please?

Thanks
(Reporter)

Comment 8

8 years ago
Sure, It's no longer required that break our dependency on OG CTA  in D6 as i now have this module working fine in D6.

The bug was initially opened to voice my concerns and to propose an alternate solution but the problem is now fixed so i have changed the status to "resolved fixed" 

Best, Paul
(Reporter)

Comment 9

8 years ago
Sure, It's no longer required that we break our dependency on OG CTA  in D6 as i
now have this module working fine in D6.

The bug was initially opened to voice my concerns about a persistent problem and to propose an alternate solution but the problem is now fixed so i have changed the status to "resolved fixed" 

Best, Paul
(Assignee)

Updated

6 years ago
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.