Should not show active state for links in editor

RESOLVED WORKSFORME

Status

P4
normal
RESOLVED WORKSFORME
18 years ago
4 years ago

People

(Reporter: sfraser_bugs, Assigned: cmanske)

Tracking

({helpwanted})

Trunk
Future
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [p:4][minus])

(Reporter)

Description

18 years ago
If you click on a link in editor, it goes red while the mouse is down (:active 
styles are being applied). We need to prevent that.

Perhaps add some CSS to set user-input: none on links? (This will work when I 
have checked in form control editing stuff).
(Reporter)

Comment 1

18 years ago
Clarify summary.
Summary: Show active state for links in editor → Should not show active state for links in editor

Comment 2

18 years ago
setting to nsbeta3+, result of the UI review
Keywords: correctness, nsbeta3
Priority: P3 → P4
Whiteboard: [nsbeta3+][p:4]
Target Milestone: --- → M18
(Assignee)

Comment 3

18 years ago
I tried this:
/* Trying to prevent coloration for link states */
a:visited, a:active, a:out-of-date {
  cursor: text;
  text-color : inherit;
  user-input: none;
}
but it doesn't work. Waiting for Simon's form control work to see if 
"user-input: none" will work.
Note that we can't set color explicitly in CSS, since we want it to be the 
same as the "normal" link color, which can be set by user.
Status: NEW → ASSIGNED
Keywords: helpwanted
Try 'color' not 'text-color'.
(Assignee)

Comment 5

18 years ago
*** Bug 43843 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

18 years ago
Thanks Ian, but using "color" didn't work either.

Comment 7

18 years ago
PDT downgrading to [nsbeta3-].
Whiteboard: [nsbeta3+][p:4] → [nsbeta3-][p:4][minus]

Comment 8

18 years ago
setting to future and adding helpwanted
Target Milestone: M18 → Future

Comment 9

17 years ago
Changing platform
Hardware: All → Macintosh

Updated

17 years ago
Keywords: nsbeta3
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Whiteboard: [nsbeta3-][p:4][minus] → [p:4][minus]

Comment 10

17 years ago
spam composer change
Component: Editor: Core → Editor: Composer

Comment 11

17 years ago
removing myself from the cc list

Comment 12

15 years ago
I supposed this was fixed a while back? wfm?

Comment 13

15 years ago
marking wfm
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.