Closed Bug 476904 Opened 11 years ago Closed 11 years ago

Crash inside nsNavBookmarks::IsRealBookmark, with "2wire.com/bandwidth" and switching from FF3.0.x mozilla-central nightly

Categories

(Firefox :: Bookmarks & History, defect)

x86
Linux
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 476292

People

(Reporter: dholbert, Unassigned)

References

()

Details

(Keywords: crash)

STR:
 1. Start Firefox 3.0.x, using a freshly-created profile
 2. Visit http://www.2wire.com/bandwidth/
 3. Click the AwesomeBar star to bookmark the site that you end up on.  (It doesn't matter the URL, as long as it begins with the URL from step 2)
 3. Quit Firefox
 4. Start a mozilla-central nightly build (using the same profile)
   -->  RESULTS: **CRASH**

And a few more steps, just for fun:
 5. Start the mozilla-central nightly build again (using the same profile)
   --> RESULTS: No Crash.
 6. Start Firefox 3.0.x, and then quit
 7. Start the mozilla-central nightly build again (using the same profile)
    -->  RESULTS: **CRASH**

Basically, steps 5-7 illustrate that this only happens on the first time you run a mozilla-central nightly after running Firefox 3.0.x.

EXPECTED RESULTS: No crash after step #4.
which nightly?
is suspect this is bug 476292
VERSION INFO:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090202 Minefield/3.2a1pre

And yes, that's the crash signature I get.  Thanks! Marking dupe.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476292
and this is indeed fixed in the latest nightly, since bug 476292's patch was checked in last night. d'oh / woo-hoo! :)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090204 Minefield/3.2a1pre
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.