search box default text doesn't go away/remains - typed search terms overlayed

RESOLVED FIXED in 5.2

Status

P4
minor
RESOLVED FIXED
10 years ago
3 years ago

People

(Reporter: aryx, Assigned: wenzel)

Tracking

Details

(URL)

Attachments

(3 attachments)

Created attachment 360600 [details]
search terms and default text overlayed

Sometimes (when I quickly set the focus to the search box at https://addons.mozilla.org/de/firefox/ ?), thesearch box default text doesn't go away/remains and overlays the typed search terms.

Browser: Gecko 1.9.0.6pre and 1.9.0.7pre with Windows XP
woah. umm.

The "Suche nach Add-ons" is just pre-filled text that gets deleted by javascript when you click.  Anyway to get text overlapping text in an <input> sounds like a bigger issue no matter when you decide to focus*.  Is there an easy way to reproduce this and is it possible in other browsers?

* If you click before the document is loaded it's possible the text won't be deleted when you start typing.  In this case your new text would be inserted into the old wherever you clicked, not over the top.
(Assignee)

Comment 2

9 years ago
I haven't been able to reproduce this, and it may be gone in the new layout. Please let us know if this still occurs.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
I still see this with Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

I can reproduce it now:
When the page loads, and the search box is already rendered/shown, quickly click into it, the default text will be added later. (Page loaded with Ctrl+Shift+R).
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Status: REOPENED → NEW
Duplicate of this bug: 515373
(Assignee)

Comment 5

9 years ago
Created attachment 399523 [details] [diff] [review]
Patch, rev. 1
Assignee: nobody → fwenzel
Status: NEW → ASSIGNED
Attachment #399523 - Flags: review?(rdoherty)
(Assignee)

Updated

9 years ago
Target Milestone: --- → 5.1
(Assignee)

Comment 6

9 years ago
There's unfortunately no way to detect if the search box has the focus already, so all we can do is blur() it unless the user has entered some text already (in which case the label doesn't show up anyway).

Anything keeping us from implementing it without a label, like I did on the dev hub? That's beyond the scope here, but I never understood the advantage of that overlaid label.
I've tried reproducing this and can't, probably due to hosting this locally and the page loads too fast.

I'm all for changing this to not use a label over the input box, always seemed like a weird way to do it. I'd vote for adding an aria role='search' to it while were there ;)
Attachment #399523 - Flags: review?(rdoherty)
Bumping to 5.2 since wenzel is afk and this is a low priority bug
Priority: -- → P4
Target Milestone: 5.1 → 5.2

Updated

9 years ago
Duplicate of this bug: 517687

Updated

9 years ago
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Comment 10

9 years ago
Comment on attachment 399523 [details] [diff] [review]
Patch, rev. 1

I know this is hard and hardly reproducible, so I suggest to r+ this if it still works and comment 6 makes sense.
Attachment #399523 - Flags: review?(clouserw)
Comment on attachment 399523 [details] [diff] [review]
Patch, rev. 1

this doesn't break it for me, but I can't reproduce anyway.
Attachment #399523 - Flags: review?(clouserw) → review+

Comment 12

9 years ago
I can reproduce it without a problem.  Is it posted to somewhere public yet?
(In reply to comment #12)
> I can reproduce it without a problem.  Is it posted to somewhere public yet?

Not yet; in order to see it:

A) It would have to be checked in to SVN (which is picked up by http://preview.addons.mozilla.org automatically, every 15 minutes or so)
B) Bug 520850 would have to be fixed so that you could see it
(Assignee)

Comment 14

9 years ago
I committed this to r52992.

DS: If you want to try it out, please wait about half an hour, then look at http://preview.addons.mozilla.org/ . Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago9 years ago
Keywords: push-needed
Resolution: --- → FIXED

Comment 15

9 years ago
Created attachment 405051 [details]
View of the issue

Still seeing the same issue.

1)Clear cache just in case.
2)Force a new load using F5
3)Image is the result when in safe mode but also had the same result in regular mode
(Assignee)

Comment 16

9 years ago
Did you type this text into the search box while the page was loading or how did the text get in there? If I type anything while the page is still loading, the label does not show up for me.

Comment 17

9 years ago
I go to the front page and type in toolbars. ("Search for Add-ons" disappears)
Press enter on the keyboard.
When the first results page appears the result is the above image.
(Assignee)

Comment 18

9 years ago
Ah, thank you. That is a different bug than comment 0, but we need to fix it as well.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 19

9 years ago
You might want to reopen this then.


https://bugzilla.mozilla.org/show_bug.cgi?id=517687
(Assignee)

Comment 20

9 years ago
Thanks, I did.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Arch, is this now fixed for you on preview?  Thanks!
Keywords: push-needed
(Assignee)

Updated

9 years ago
Duplicate of this bug: 504840
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.