when I tried to log in on the South Beach Diet website (which I belong to) I get a page that says: Length Required

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: hedgymom, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.19) Gecko/20081212 Camino/1.6.6 (like Firefox/2.0.0.19)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.19) Gecko/20081212 Camino/1.6.6 (like Firefox/2.0.0.19)

I tried to log in to a website (www.southbeachdiet.com). When I did so, a page came up that said: Length Required.
The URL is:

http://www.southbeachdiet.com/sbd/publicsite/recipes/flourless-chocolate-orange-torte.aspx

Reproducible: Always

Steps to Reproduce:
1.Go to www.southbeachdiet.com
2.do the log in
3.above URl with the page saying: Length required
Actual Results:  
as I said,above.

Interestingly, this does not happen with the following browsers:
Safari


On Firefox, I get this message:


We're sorry...

We're having difficulty fulfilling your request. Please try the following:

    * Use your browser's Back button and try again
    * Return to the SouthBeachDiet.com home page

If you still encounter an error, please contact Customer Care at support@southbeachdiet.com, and include the following:

    * What you were trying to do when you reached this page
    * What kind of computer (Windows or Mac) you have
    * What kind of web browser you are using (Internet Explorer, Firefox, etc.), including the version number if you know it



Expected Results:  
I should have been able to log in.
I can log in on Safari.
I cannot log in on Camino OR Mozilla Firefox.

Versions I'm using:
Mac OS 10.5.6 on an iMac 8,1

Version of Firefox:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

Version of Camino:
Version 1.6.6 (1.8.1.19 2008121219)

Comment 1

10 years ago
Sounds like a server problem to me, one that Safari is ignoring (likely in one of their many violations of the HTTP spec).

We're probably not going to be able to troubleshoot this further without an account, though.

Comment 2

10 years ago
I've sent a private e-mail to Melissa requesting her login information for this site. I'll look into the HTTP headers once I get that information, but I suspect they're sending a broken HTTP header.

Melissa, can you attach a screen shot of the error in Camino? Command-Shift-4 will let you select an area of the screen to take a screen shot, and then you can use the "Add an attachment" link above to attach the picture to this bug.

Comment 3

10 years ago
Melissa, I still haven't heard back from you, either about the login information or in response to the question I asked in comment 2. Can you please answer both of those?

Comment 4

10 years ago
WORKSFORME (see bug 476901 comment 5), since we don't know what the problem was. Suspect INVALID, though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.