Closed Bug 477091 Opened 11 years ago Closed 10 years ago

shortcuts for opening calendar or tasks tab don't work, new shortcuts required

Categories

(Thunderbird :: Toolbars and Tabs, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b4

People

(Reporter: maxxmozilla, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(2 files)

Bug 466019 "killed" them.
Flags: blocking-calendar1.0?
Proposals ?
Bryan, could you propose a solution for this issue? I really don't like what was done in bug 466019, but I guess thats just the way things go (or are copied from firefox)
Assignee: firefox → clarkbw
Flags: tb-integration?
Flags: blocking-calendar1.0?
Flags: blocking-calendar1.0+
The original configuration of accel+number was just picked out of the air with no real cognitive mapping; this change at least builds that.

bug 466019 Comment #30 and bug 466019 Comment #31 have some proposals for the address book command change.  We should aim to keep these all similar if possible.  

What does Outlook use as accel keys for calendar and tasks?
(In reply to comment #3)
> What does Outlook use as accel keys for calendar and tasks?
Ctrl+1 - Mail
Ctrl+2 - Calendar
Ctrl+3 - Contacts
Ctrl+4 - Tasks
...
Maybe we wanted too much mimic Firefox and I originally wanted working 1st point, new tab shortcuts are surely useful but it would be probably hard to find good piece of key combinations for the removed shortcuts.
(In reply to comment #4)
> Maybe we wanted too much mimic Firefox and I originally wanted working 1st
> point, new tab shortcuts are surely useful but it would be probably hard to
> find good piece of key combinations for the removed shortcuts.

If outlook had a tabbed interface like we are building then that could be true.  However considering the Thunderbird tabbed interface and the significant overlap of users with firefox, we gain significantly by keeping elements that look similar using similar interactions.
Free accels: B, H, J, Q

Some proposals for possible new calendar/tasks shortcuts:

1. Change them from accel to alt (this would require change to calendar views shortcuts...)

2. accel+F1-4

3. alt+F1-3 (alt+4 can't apply here ;)
(In reply to comment #6)
> Free accels: B, H, J, Q
> 
> Some proposals for possible new calendar/tasks shortcuts:
> 
> 1. Change them from accel to alt (this would require change to calendar views
> shortcuts...)
I think this causes problems on some platforms (i.e mac)

> 
> 2. accel+F1-4
This causes my pinky finger to hurt after a while

> 
> 3. alt+F1-3 (alt+4 can't apply here ;)
I think this is too close to Alt+F4 and users might accidentally close the app.
Whiteboard: [needed beta][has l10n impact][needs decision bryan or philipp]
> > 2. accel+F1-4
> This causes my pinky finger to hurt after a while
these shortcuts would be probably used by a minority of users and even then rather not as often to cause pain ;)
(they are the closest replacement of the previous ones)

what shortcuts would you like ?
Keywords: regression
Summary: change calendar and tasks shortcuts to working ones → shortcuts for opening calendar or tasks tab don't work, new shortcuts required
Since Ctrl-Shift-B now opens the Address Book, how about these:

Ctrl-Shift-C   Calendar
Ctrl-Shift-T   Tasks

FWIW, people can use the keyconfig extension if they don't like them.
Wait a minute, I am a bit confused now:

On Linux:
In beta 2, With alt+1,2,3 I can switch to a numbered tab
In Calendar, these combinations are used to switch between Day,Month,Week View.


I like the idea of Ctrl+Shift+C/T if its needed, but right now, Ctrl+3,4 doesn't seem to actually do anything in beta2?
Ctrl-Shift-C is "Mark all read" so that can't be used for calendar. Ctrl-Shift+T is "Check all accounts for new mail"

Yes, it's "alt + number" instead of "ctrl + number" on linux (only), to mirror what firefox does.
Fun stuff, so this means both our alt+[1234] and ctrl+[34] shortcuts are screwed, depending on platform? Which in turn means we need to think of alternatives for both?

This is really starting to get out of hand, while I see the reasoning for mimicing firefox, you are not leaving us with many options here, other than moving to shortcuts that aren't really memorable or won't be often use since it requires advanced finger acrobatics.
Yeah, it's unfortunate :( Not that I think alt+number would have been great calendar shortcuts anyway.

We may have to sacrifice some existing shortcut so calendar can have a decent one.
So given the current circumstances I'm tempted to just drop the keyboard shortcuts for Calendar/Task and the views altogether. There is no sense in just picking any set of shortcuts that are still free and I haven't seen a viable alternative to Ctrl+[34] to switch to the Calendar/Task tabs.

After sacrificing the mode toolbar with only two very small buttons as a replacement, this gives the user even less possibilities to quickly switch to calendar and task mode.

This is really aggrivating for me, tb-integration is now one step further away. I think the Thunderbird Team should have taken Calendar into account before changing these keyboard shortcuts. At least a more prominent notice to encourage discussion would have been nice.
One note: once tab/session restore is implemented, then the ctrl-Num keyboard shortcuts should allow for pretty good keyboard UX for consistent lightning users, IMO.

That said, I'm also fine w/ getting rid of some not-oft-used keyboard assignments to make them usable for lightning.
The problem is, I rather need a solution for now since we want to have something for our milestone, which we are already pretty late on. Of course we could skip this release and wait for beta 3, but I doubt thats wanted.
I could suggest to open calendar and tasks tabs with ctrl+3,4 if there are less than 3 tabs opened but this is rather bad UI...

What about opening calendar and tasks tabs by default ?
then ctrl+2,3 would allow to switch to them without the need to use some (or not) strange shortcut (better discoverability).
Group: mozilla-confidential
Group: mozilla-confidential
I can see the tab changes have effected the calendar shortcuts quite a bit.  The address book shortcut was effected in a very similar way and with bug 478415 marco brought up how it's important to get something in that makes sense.

Ctrl+Shift+C/T seems like a good combo

Like david pointed out, our future goal is to rely on tab session restore ( bug 459096 ) so that calendar and tasks tabs are auto-reopened and are easily accessible through the tab shortcuts.    The tab restore window has a lot of possibility for calendar to use for better user experiences, it would be really good to get your thoughts in that area.
Ctrl+Shift+C is already in use for "Catch up" a.k.a. "Mark all read".
As is Ctrl+Shift+T for check all new accounts. Though if we're going to move Ctrl+T to "new tab" anyway that could indeed be one to sacrifice, especially as we already have F5 for check mail, so Shift+F5 could be ok for "Check all" perhaps?

And make "Mark all read" be Shift+C, like it used to be on linux? At least it's undoable now for tb3 so... 

So, the would make:
 o Ctrl+Shift+C: calendar
 o Ctrl+Shift+T: tasks
 o Shift+C: mark all read
 o Check all accounts: Shift + F5/F9
Thanks for the ideas and the willingness to sacrifice tb3 keys. I think we should head for the final solution instead of fixing this for our milestone. IIRC, the state we are in now w.r.t the hotkeys doesn't hurt us.

While I think session restore is a great feature and will make both developing and using much more pleasant, I still think we need the hotkeys, i.e to quickly switch to your calendar if you have many open tabs.
Whiteboard: [needed beta][has l10n impact][needs decision bryan or philipp] → [not needed beta][has l10n impact]
Given the large number of Thunderbird users on windows, it would be interesting to know what keystrokes Outlook uses for this...
(In reply to comment #22)
See comment #4 above.
Duplicate of this bug: 483345
Moving this to thunderbird land to get more traction on it. We need this fixed asap, or at least before beta 3
Assignee: clarkbw → nobody
Component: Lightning Only → Toolbars and Tabs
Flags: tb-integration?
Flags: blocking-calendar1.0+
Product: Calendar → Thunderbird
QA Contact: lightning → toolbars-tabs
Whiteboard: [not needed beta][has l10n impact]
Target Milestone: --- → Thunderbird 3.0b3
Flags: blocking-thunderbird3?
Assignee: nobody → clarkbw
Severity: trivial → major
Flags: blocking-thunderbird3? → blocking-thunderbird3+
I'll put this for m4 as I'm not actively working on new solutions right now.  I think what we have looks pretty good except for the Ctrl+Shift+T key binding.  Ctrl+Shift+T is reserved that for a future undo tab close.

So that gives us this:

 o Ctrl+Shift+C: calendar
 o ???: tasks
 o Shift+C: mark all read
 o Check all accounts: Shift + F5/F9

Using Ctrl+Shift+D would at least give us Addr Book, Calendar, Tasks following the alphabet.
Whiteboard: [m4]
Whiteboard: [m4] → [m6]
Ok, here's my recommendation:

 o Ctrl+Shift+C: calendar
 o Ctrl+Shift+D: tasks
 o Shift+C: mark all read
 o Check all accounts: Shift + F5/F9

I put those into the wiki page: https://wiki.mozilla.org/Thunderbird:Keybindings
Whiteboard: [m6] → [m6][needs patch]
(In reply to comment #12)
> Fun stuff, so this means both our alt+[1234] and ctrl+[34] shortcuts are
> screwed, depending on platform? Which in turn means we need to think of
> alternatives for both?

Due to the platform differences, we also need new shortcuts for changing the calendar views.
(In reply to comment #28)
> Due to the platform differences, we also need new shortcuts for changing the
> calendar views.

Is there another bug for that?  I'm concerned that we won't be able to block the b3 release if we inflate the scope of this bug.  Maybe we should land the changes needed to make the shortcuts for opening cal & tasks and file a blocker for rc1 with the changing calendar views shortcuts.
While I admit I didn't change the topic, I thought it was clear that this bug is about both, since the bug that caused this regression also broke both shortcuts and due to discussion in comments ~10-13
Philipp, I think the point Bryan was trying to make was merely that if we split this bug into two patches, we can get the first patch in sooner rather than keeping everything from landing until all the work is done.  Are you ok with that?
Sure, fine with me, as long as a possibly new bug is also blocking-tb3.
That makes sense to me, this way we can get smaller patches landed and get some testing on them while we work out other decisions
Duplicate of this bug: 498093
I'd like to see this for 3.0b3, just wanted to make sure its not forgotten :-)
I'll grab this.
Assignee: clarkbw → mkmelin+mozilla
Status: ASSIGNED → NEW
Attached patch proposed fix β€” β€” Splinter Review
o Ctrl+Shift+C: calendar
 o Ctrl+Shift+D: tasks

Calendar view switching is now ctrl+number on linux. (I removed the entities - I don't think those are really localizable more than by accident as alt is reserved menu access on win/lin at least)

 o Shift+C: mark all read (Was Ctrl+Shift+C)
Attachment #386031 - Flags: ui-review?(clarkbw)
Attachment #386031 - Flags: review?(philipp)
Attachment #386031 - Flags: review?(philringnalda)
Comment on attachment 386031 [details] [diff] [review]
proposed fix

Getting philor to review the one-liner mail/ change
Whiteboard: [m6][needs patch] → [m6][needs reviews]
Status: NEW → ASSIGNED
Attachment #386031 - Flags: ui-review?(clarkbw) → ui-review+
Comment on attachment 386031 [details] [diff] [review]
proposed fix

>+      <key id="openLightningKey" key="&lightning.keys.event.showCalendar.key;"
>+           modifiers="accel, shift" observes="new_calendar_tab"/>
>+      <key id="openTasksKey" key="&lightning.keys.event.showTasks.key;"
>+           modifiers="accel, shift" command="new_task_tab"/>
We have been using one attribute per line when wrapping.


r=philipp for calendar
Attachment #386031 - Flags: review?(philipp) → review+
Comment on attachment 386031 [details] [diff] [review]
proposed fix

My only real feeling about our wrapping is "I don't care what you do, as long as you don't do what's there now!"
Attachment #386031 - Flags: review?(philringnalda) → review+
So does this have to wait until the calendar string freeze is over? Or is there some approval process, late-l10n type of thing?
Whiteboard: [m6][needs reviews] → [ready to land]
(In reply to comment #41)
> So does this have to wait until the calendar string freeze is over? Or is there
> some approval process, late-l10n type of thing?

Yes, it would be a shame not to get this in their beta 1 having fixed it so that we could get it into TB 3 beta 3.
The only l10n changes are removing some unused entities, so I don't think this justifies late-l10n. Just go ahead and check in the patch without removing the entities, I'd appreciate if you could file a followup bug to remove those entities after beta1.
Well i'm also adding two entities (the two new keys), so it would seem to me we should either get this in completely now, or then wait.
Maybe hard code the new keys for the checkin during string freeze and replace them with the new entities afterwards?
Sorry for the delay, I thought I answered this. Given we would need a cleanup bug anyway, I'm fine with hardcoding the entities for now.  I think we should stick to the string freeze as much as possible, since we are already in the middle of it.
Nits addressed - this is the version to check in after string freeze
changeset:   3017:129da8379d42
http://hg.mozilla.org/comm-central/rev/129da8379d42

I'll just leave this open and do the l10n checkin after string freeze
Whiteboard: [ready to land] → [fix 1l0n after tb3b3/lightning string freeze]
Target Milestone: Thunderbird 3.0b3 → Thunderbird 3.0b4
Whiteboard: [fix 1l0n after tb3b3/lightning string freeze] → [fix l10n after tb3b3/lightning string freeze]
(In reply to comment #48)
> changeset:   3017:129da8379d42
> http://hg.mozilla.org/comm-central/rev/129da8379d42
> 
> I'll just leave this open and do the l10n checkin after string freeze

Why is that bug targeted b4 ?
Keywords: relnote
Because for b4 is when i expect to have it all wrapped up with proper localization checked in.
Whiteboard: [fix l10n after tb3b3/lightning string freeze] → [fix l10n needed]
Magnus, when are you planning to land this?
(In reply to comment #51)
> Magnus, when are you planning to land this?

Afaik after Lightning 1.0 beta release, means after lifting the related string freeze for Calendar.
Whiteboard: [fix l10n needed] → [fix l10n needed][waiting on Lightning string freeze to finish][has l10n impact]
Ok, so if now I read it again I understand this correctly, then:

- the Thunderbird parts are fixed.
- the Lightning string changes need to land after Lightning releases its beta.

As there is no more work on the Thunderbird side, removing this bug from the Thunderbird blocking list as there is nothing to track here from the Thunderbird perspective.
Flags: blocking-thunderbird3+ → blocking-thunderbird3-
Whiteboard: [fix l10n needed][waiting on Lightning string freeze to finish][has l10n impact] → [fix l10n needed][waiting on Lightning string freeze to finish]
Localized version checked in.
changeset:   5098:3c77d8ffabfa

http://hg.mozilla.org/comm-central/rev/3c77d8ffabfa

->FIXED!
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [fix l10n needed][waiting on Lightning string freeze to finish]
Thanks for taking care, I totally forgot about this one!
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.