Add To Firefox for new search engines takes very long to work

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: kberk.spamaway, Unassigned)

Tracking

3.5 Branch
x86_64
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b3pre) Gecko/20090205 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b3pre) Gecko/20090205 Shiretoko/3.1b3pre

Litmus test "View search plugins directory" fails.

Specifically when you tell Shiretoko to "Add to Firefox", nothing seems to happen.  Then two minutes later you get the confirmation dialog box.

Reproducible: Always

Steps to Reproduce:
1 Open the search box menu to the left of the search box
2 Choose 'Manage Search Engines...'
3 Click 'Get more search engines'
4 Click on an engine

Actual Results:  
Nothing appears to happen at first.

1-2 minutes later a confirmation dialog box appears.

Expected Results:  
A confirmation dialog box should open right away.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.1 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090205 Shiretoko/3.1b3pre

This works fine for me. I installed the first 10 engines without delay, only the Baidu plugin took some more seconds, the rest popped up within 1 or 2 seconds.
Component: General → Search
QA Contact: general → search
Works for me too with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090831 Shiretoko/3.5.4pre ID:20090831030742

Reporter, if you can still see this problem with Firefox 3.5.2 feel free to reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.