Scrolling through full history, brought up the hour glass then history section of Firefox crashed

RESOLVED INCOMPLETE

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: Neil Robinson, Unassigned)

Tracking

3.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

Firefox updated automatically this morning.

I opened two tabs (my own website, http://www.lanzen.co.uk/portal.php) and my Zimbra email site (https://zimbracs.simplyms.com/zimbra/?initMode=http&client=advanced#1).

I clicked on History from the main menu, then Show All History. I started to scroll and the hour glass appeared. This section then froze. I closed it via the taskbar program bar at the bottom of XP and got "program not responding".

It closed, but locked up Firefox, which also came back "program not responding."

Reproducible: Didn't try
how is your history setup in preferences, how many days are you remembering?

Can you try to reproduce the issue in safe mode? http://support.mozilla.com/kb/Safe+Mode
(Reporter)

Comment 2

9 years ago
Hi, Marco,

I have just ried again, but can't reproduce the crash.

Specifically, I opened up Show all history and using the scroll wheel on my mouse, tried to scroll down the pages.

It started to scroll then froze with the hour glass.

I clicked "close" on the "library" program bar on the bottom XP Toolbar.

I've got a long history as I rarely delete it...

Hope that helps!

NeilR
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7pre) Gecko/2009012506 GranParadiso/3.0.7pre

I tested this but couldn't reproduce it. The slider doesn't instantly follow my movements but this is not a very speedy computer.. with the scroll wheel no problem.
Version: unspecified → 3.0 Branch
Ok, I can confirm this bug with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090521 Shiretoko/3.5pre ID:20090521135222

You really need a lot of history items in your database otherwise you will not see it. There are several paths to see this behavior:

* History Sidebar (Screencast: http://screencast.com/t/dYjQoWVH1oP)
1. Open History Sidebar and select Last Visited and Close the sidebar
2. Open the sidebar again and try to scroll => FAIL
3. Select By Date option and scroll => PASS
4. Select Last Visited option again and scroll => PASS

* All History
1. Open the Library window
2. Select a month under the history container with a lot of entries
3. Try to scroll => FAIL
4. Select another folder and go back to the folder from 2.
5. Try to scroll again => PASS

So it happens only the first time when a tree with a big amount of items will be scrolled. Successive tries will succeed.

No idea if this is an underlying XUL tree issue. Neil, have you seen such an behavior in the past?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
if you saw the crash reporter tool after the crash you should be able to find the crash stack in about:crashes address. if you can point us to the crash report would be useful.
missing a stack for this old bug.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 7

7 years ago
Can't contribute anymore to this - I've downgraded to 32-bit Ubuntu, so cannot check this on any new versions.
Resolution: INCOMPLETE → WONTFIX
Resolution: WONTFIX → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.