[MIR] PPC64 compile problem under Xcode

VERIFIED FIXED

Status

VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: lhansen, Unassigned)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

383 bytes, patch
edwsmith
: review+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
Created attachment 360896 [details] [diff] [review]
Patch

The compiler complains about a cast in the MIR code.  Here's a simple fix for that; more likely the problem is that the MIR code should not be compiled at all for PPC64 now that we have LIR support.
Attachment #360896 - Flags: review?(edwsmith)
(Reporter)

Updated

10 years ago
Blocks: 468122

Comment 1

10 years ago
Comment on attachment 360896 [details] [diff] [review]
Patch

Correct, AVMPLUS_MIR should not be turning itself on with PPC && 64BIT.  the cast looks fine but MIR has no chance of working as-is on PPC64.
Attachment #360896 - Flags: review?(edwsmith) → review+
(Reporter)

Comment 2

10 years ago
I'll push this fix then, just for the sake of argument, since it's blocking the xcode project files.  Do you want to look into the necessary mojo to disable MIR for this configuration?
(Reporter)

Comment 3

10 years ago
Created attachment 360902 [details] [diff] [review]
A further fix

Turns out that the problem is in SparcAssembler.cpp, which includes CodegenMIR.h without checking whether MIR is enabled (actually the entire file depends on MIR being enabled but is not protected).  Adding the obvious #ifdef fixes this.
Attachment #360902 - Flags: review?(lhansen)
(Reporter)

Comment 4

10 years ago
redux changeset:   1410:bd3008173b76
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Attachment #360902 - Attachment is obsolete: true
Attachment #360902 - Flags: review?(lhansen)

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.