Closed Bug 477236 Opened 11 years ago Closed 10 years ago

single pixel horizontal white lines in iframes when scrolling

Categories

(Core :: Graphics, defect, P1)

x86
Windows Vista
defect

Tracking

()

RESOLVED FIXED
Tracking Status
status1.9.2 --- beta1-fixed

People

(Reporter: kbrosnan, Unassigned)

References

()

Details

(Keywords: regression, testcase)

Attachments

(2 files)

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090205 Minefield/3.2a1pre

1) load the url above
2) scroll down on the page
3) as the flash ad appears white lines run through the ad 250x300 at the end of the story

The site does not always show flash ads. Flash ads with motion don't exhibit the issue. Does not appear in the 1.9.1 branch. Does not appear if you load a problem page in the dom inspector.

Working on a regression date.
Flags: blocking1.9.2?
I also still see the lines in the locationbar autocomplete.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090206 Minefield/3.2a1pre

Sorry, FWIW, with the latest build I see no lines anymore.
Looks to work in Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090114 Minefield/3.2a1pre

Fails in Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090115 Minefield/3.2a1pre
Still see the issue with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090206 Minefield/3.2a1pre

It helps to hold down the middle mouse button to scroll to produce the number of white lines shown in the top of the attached image. The last white line in the image is from rolling the scroll wheel one click.
Just to confirm before I panic -- this is not happening in 1.9.1, correct? Just 1.9.2?
Flags: blocking1.9.2? → blocking1.9.2+
Priority: -- → P1
That is correct. Only 1.9.2 builds show the issue.
Thanks; from looking at the changeset range, the one that stands out is bug 448830.
I think I managed to generate the bug once without flash.  On the square ads below the article.

Looking at one example with a flash ad, it had a 300x250 iframe with the flash object inside that.  White lines always appear at the edge of the screen after scrolling, so that means the rectangle for either the object or the iframe is being clipped to the client area and then rounded in such a way that it is coming up one pixel short.

I've looked over the patch from bug 448830 and I can't find anything.  All the major cases of changes in rounding are either not on Windows or only change the cursor, I think...  The minor cases are all float rounding, where the math should be more accurate now.

I did notice the page generating a lot of assertions for "computed overflow area must contain frame bounds".
That assertion is quite bad. We should probably track it down. A reduced testcase would be useful.
Attached file testcase
When scrolling down, I get white lines.
I tried to make a testcase with drawWindow canvas to capture the painting bug, but I didn't succeed.
OK, I see a white line at the bottom of the window on Mac.
I'm also seeing this bug at http://alleskanhier.blogspot.com/
Duplicate of this bug: 483491
Summary: flash ads have white lines in them → random single pixel horizontal white lines when scrolling
Summary: random single pixel horizontal white lines when scrolling → single pixel horizontal white lines in iframes when scrolling
FWIW, I don't think iframes or scrolling are required here. I encountered this problem in bug 477519 with just a scaled image. No iframe, and scrolling actually made the glitches disappear.
I suspect that bug 477519 is not the same bug, although it was also exposed by bug 448830.  When I can find some time to look at this, this bug will be a rounding problem with views which are not pixel aligned, but which bug 448830 didn't fix.  bug 477519 will be a similar problem but with the computation of the damage rectangle for a scaled image.  Both will be computations relying on an inner and outer rectangle being done in exactly the same way, and one is using height = round(height/scale) and the other is now using height = round(height+y)/scale-round(y/scale) (for some value of round).
Why do we think this is a 3.6a1 blocker?
I think this should be fixed by bug 503814 (at least, if not roc's compositor landings), but I couldn't reproduce using the testcases in this bug so I didn't mark the dependencies. Anyone able to verify this is fixed?
I could not reproduce the issue with the testcase using my build from this morning on Windows 7. I also checked the url and none of the many flash ads had lines when I scrolled.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I was hoping someone who could reproduce in this bug before could check if they can reproduce now, since I was never able reproduce on the testcases in this bug, but could reproduce what sounded like the same problem on my own testcase.
Duplicate of this bug: 500924
Mass change: adding fixed1.9.2 keyword

(This bug was identified as a mozilla1.9.2 blocker which was fixed before the mozilla-1.9.2 repository was branched (August 13th, 2009) as per this query: http://is.gd/2ydcb - if this bug is not actually fixed on mozilla1.9.2, please remove the keyword. Apologies for the bugspam)
Keywords: fixed1.9.2
You need to log in before you can comment on or make changes to this bug.