with Cache, Provider for Google Calendar loses alarms and categories on event edit / alarms and categories cannot be added to existing events

RESOLVED FIXED in 1.0

Status

defect
--
critical
RESOLVED FIXED
11 years ago
7 years ago

People

(Reporter: Curunauth, Assigned: Fallen)

Tracking

(Blocks 1 bug, {dataloss})

unspecified
x86
Windows XP
Dependency tree / graph

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18pre) Gecko/20080917 Sunbird/0.9

In google calendars (subscribed via Provider, using private iCal link) with caching turned on, events can be created with alarms and categories, but any edit of the event (single or recurring) causes the alarms and categories to be removed. Also, alarms and categories cannot be added to existing events, so those lost are permanently gone.

This may be two bugs, but it seems to be a single phenomenon.

Very rarely, attempts to add alarms/categories produce an error (update failure), but this is likely to be an unrelated event. Usually this occurs without error or warning.


Sunbird 0.9, Provider 0.5.1, WinXP SP3. TBird not installed.
Using cache. Cannot reproduce on non-cached calendars.

Reproducible: Always

Steps to Reproduce:
1. Subscribe to any google calendar, and turn on caching.
2. restart to enable cache.

3. Add a category or alarm to an existing event, and save
OR
3. Create an event with a category and/or alarm on a Google Provider calendar
4. Edit the event - change anything, then save it.
Actual Results:  
In either case, I end up with an event containing all the changes except for categories and alarms, which are gone.

Expected Results:  
The event should have alarms and/or categories

Similar to an old closed Lightning bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=457890
(Last comment there (Oct 2008) mentions that the fix appeared not to work.)
But again, only applies to cached calendars.
Have you tested this with Sunbird 1.0pre/Provider 0.6pre?
this sounds about right....  I lost a lot of alarms in the same way and i was trying to use tbird 2.0.21,  lightning 0.9, & provider 0.5.1 on linux (fedora10)...  

i haven't tested this with 0.6pre and the tb3b2, but I'm sufferring too much setback in the pursuit of this calendaring nonsense.  I'm unwilling to trust lightning with the ability to make me lose and miss my appointments, unless I get to see what the heck it's doing when it syncs to the network calendar.

I need to be able to confirm all changes that get uploaded.  losing alarms and other random changes is totally unacceptable...  i've now got alarms on events that didn't have them, no alarms on repeating events that started in the past, and a whole bunch of duplicate events because these changes caused confusion for palm desktop's sync.  so much for productivity!

so there's a flag in the about:config for enabling debugging, but i recommend going further.  At this point, I really really really need to see what changes to my agenda lightning is planning to write to my calendar...
I can confirm this with Windows XP SP3 & 7 RC; Thunderbird 3b2; Lightning 1.0pre nightly build downloaded 24 June 2009; Provider for google calendar 0.6pre downloaded 24 June 2009.

My experience of the bug is exactly the same as Curunauth.

Hope this gets fixed soon...
Confirmed per comment#3 for Lightning 1.0pre & gdata 0.6pre.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I don't seem to have to same problem when I just edit an event, however I noticed that when I move an event from one calendar to another (both of them are google calendars), the reminder disappears.

To test further, I created two local calendars, and it doesn't seem to be the same problem when I move between two local calendars, or even when I move between a local and a google calendar (both directions worked).

The problem only seems to occur when I move an event between two google calendars.

Windows XP SP3
Thunderbird 2.0.0.23
Lightning 0.9
Provider for Google Calendar 0.5.4
Duplicate of this bug: 540064
Duplicate of this bug: 528811
Due to marking my previous Bug 528811 as dup of this one here, and I am not sure, if its problem description is entirely covered with this bug here, I would like to add the following part of my previous bug (because it has the same reason/background and therefore belongs to this bug here):

The obove described problem also occurs after I got an alarm and say "remind me again in X min.". Then the alarm is also complety removed from that calendar item (and is synced without any alert to my Google Calendar).
In that case the removed alert can also not be set again.
I confirm this bug for Lightning/1.0b1 Thunderbird/3.0.1 and Provider for Google calendar 0.6b1. Also confirm the "remind me again" issue from comment 8.
Severity: normal → critical
Keywords: dataloss
The bug still occurs in TB 7.0, Lightning 1.0b7, Provider 0.9pre.

I enabled logging to see what happens - no error or warning, the edited object just doesn't contain any alarms.
Posted patch Fix - v1 โ€” โ€” Splinter Review
I'm going to take this patch without review, its quite obvious and low risk.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #569766 - Flags: review+
Comment on attachment 569766 [details] [diff] [review]
Fix - v1

Review of attachment 569766 [details] [diff] [review]:
-----------------------------------------------------------------

Works! For both the issues described (changing alarm for existing events with alarms, and snoozing a displayed alarm). Thank you very much!!!
comm-central changeset cfc7b233b925
releases/comm-aurora changeset 3198c5a395ea
releases/comm-beta changeset 359d0ea7f24d
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0b8
I'm sorry, I am new here! I have the same issue, how can I use the patch posted in attachment to solve my problem? I supose I need to change some config files but I didn't find a step by step tutorial on how to use the .diff file.. (i'm using Windows 7 64 bit, with Thunderbird 11.0.1, Lightning 1.3 and Provider for Google Calendar 0.9)
(In reply to Patrizia from comment #14)
> I'm sorry, I am new here! I have the same issue, how can I use the patch
> posted in attachment to solve my problem? I supose I need to change some
> config files but I didn't find a step by step tutorial on how to use the
> .diff file.. (i'm using Windows 7 64 bit, with Thunderbird 11.0.1, Lightning
> 1.3 and Provider for Google Calendar 0.9)

Using patches attached to a bug requires compiling one's own calendar, something which IMHO is not for newbies, especially since the versions of Thunderbird, Lightning and the Provider for Google Calendar must agree. This means that a patch meant for the Calendar versions corresponding to Thunderbird 12 will not necessarily work unchanged (it might not even apply without changes, something known as "bit-rot") in the Calendar source for Thunderbird 11.

I recommend that you upgrade to a newer version (later than comment #13) of Thunderbird, Lightning and the Provider for Google Calendar.

See https://developer.mozilla.org/en/Calendar/Calendar_Versions about which versions of Lightning and Thunderbirds agree, and where to find them. The "proper" version of gdata-provider.xpi is the one found in the same FTP directory as the "proper" version of lightning.xpi
See also bug 735619 (fixed in Calendar versions for Thunderbird 12) which often exhibits symptoms very similar to this one.
Thank you so much, I now have thunderbird 12.0 and lightning 1.4 with Provider for Google Calendar 0.9 and everything works without problems!
You need to log in before you can comment on or make changes to this bug.