If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thunderbird doesn't support <category> item element in RSS 2.0 feeds

RESOLVED DUPLICATE of bug 946279

Status

MailNews Core
Feed Reader
--
enhancement
RESOLVED DUPLICATE of bug 946279
9 years ago
4 years ago

People

(Reporter: LRN, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2a1pre) Gecko/20090206 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b3pre) Gecko/20090207 Shredder/3.0b2pre

http://www.rssboard.org/rss-specification#ltcategorygtSubelementOfLtitemgt describes <category> element of an RSS 2.0 <item>. Due to lack of support for this element some feeds are hard to read, because feed items from [completely] different categories will end up in the same Thunderbird folder and there's not way to tell them apart.

Reproducible: Always

Steps to Reproduce:
1. Subscribe to http://www.ibm.com/developerworks/views/opensource/rss/libraryview.jsp .
2. Observe the items you're getting from that feed.
3. Open http://www.ibm.com/developerworks/views/opensource/rss/libraryview.jsp in Firefox 3.
4. View->Page Source.
5. Search for <category> and you'll see that some of the feed items are tutorials while others are articles.
Actual Results:  
All feed items are placed in one folder. Thuderbird never indicates in any way that they are from different categories. It is impossible to use filters to separate them.

Expected Results:  
Feeds should be placed in different folders or marked as being from different categories. Thunderbird should show item's category in the list or at least when the item is displayed. It should be possible to use filters to filter by category.

1) Thunderbird RSS parser should be made aware of this element. Apparently, at the moment it just skips it as unknown.
2) At the very least this element should be available as a "header" for filters, so people can move items around based on their category.
3) Thunderbird may either display item's category in separate column or separate items from different categories placing them into different folders. I'm not sure what's the correct way of handling categories, so point (3) is optional, but (2) is not.

For example, this feed ( http://www.ibm.com/developerworks/views/opensource/rss/libraryview.jsp ) has two categories - Tutorials and Articles. Someone who is only interested in reading tutorials is nevertheless forced to read both tutorials and articles, because Thunderbird doesn't know the difference and places both in the same folder. Even after they are displayed it is impossible to tell them apart (even if one looks at the "message source").

Comment 1

9 years ago
Strangely I didn't find a dupe. Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
(Reporter)

Comment 2

7 years ago
In case anyone wants to pick this up, an adequate feed to test Thunderbird upon is http://rss.news.yahoo.com/rss/topstories , since the IBM feed i've mentioned previously does not use categories anymore. Also, any site based on Livestreet CMS is likely to place comma-separated tag list of a blogpost into <category> tag in RSS feeds.

Updated

4 years ago
Depends on: 946279

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 946279
You need to log in before you can comment on or make changes to this bug.