Closed Bug 477405 Opened 12 years ago Closed 10 years ago

TUnit failures don't display anything in tinderbox cell

Categories

(Release Engineering :: General, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dbaron, Assigned: bear)

Details

(Whiteboard: [unittest][tinderbox][oldbugs][triagefollowup])

When a TUnit test fails, it doesn't display anything to indicate that failure in the cell on tinderbox.  It simply displays a lower number of passed tests (but doesn't indicate that any failed).  It does (as it should) turn the build orange.

For example, in http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1234023066.1234028698.27208.gz the only indication of the failure is:
 * cell is orange
 * TUnit reports 287/0 rather than the old 567/0

Instead, something should appear in the cell on tinderbox, such as "TUnit fail".
(Note that this led to confusion this morning; see bug 88831 comment 104, bug 88831 comment 110, bug 88831 comment 111.  That's why I'm filing it.)
The error was

Running TestWinTSF (bug #88831) tests...
TSF not initialized properly (TSF is not enabled/installed?)
FAIL TestFocus: document focus was not set
FAIL no text store (clustering)
Testing TSF support in text input element...
FAIL no text store (input)
Testing TSF support in textarea element...
FAIL no text store (textarea)
Finished running TestWinTSF (bug #88831) tests.
make[2]: Leaving directory `/e/builds/moz2_slave/mozilla-central-win32-unittest/build/objdir/widget/tests'
make[1]: Leaving directory `/e/builds/moz2_slave/mozilla-central-win32-unittest/build/objdir/widget'
make[2]: *** [check] Error 1
make[1]: *** [check] Error 2
make: *** [check] Error 2
program finished with exit code 2

which is a non-xpcshell based test.

The code path for what tinderbox is using ends up at 
  http://hg.mozilla.org/build/buildbotcustom/file/tip/unittest/steps.py#l201

We probably need to do something like this
  http://hg.mozilla.org/build/buildbotcustom/file/tip/unittest/steps.py#l68
only testing for FAILURE as superResult.
Moving to future till we have time to work on this.
Component: Release Engineering → Release Engineering: Future
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 451474
Not a duplicate based on reading the summaries (and initial comments) in the bugs.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Mass move of bugs from Release Engineering:Future -> Release Engineering. See
http://coop.deadsquid.com/2010/02/kiss-the-future-goodbye/ for more details.
Component: Release Engineering: Future → Release Engineering
Priority: -- → P3
Is this still a problem ?
Priority: P3 → P5
Whiteboard: [unittest]
Assignee: nobody → jhford
Assignee: jhford → bear
Whiteboard: [unittest] → [unittest][tinderbox][oldbugs][triagefollowup]
Since we are trying to not add more features to Tinderbox as it is replace by TBPL and since test log data is now available from bug 530318 this leads me to want to WONTFIX this.

If there is data on the buildbot side that will make the TBPL change easier to manage then we can open a bug to get that data.
Status: REOPENED → RESOLVED
Closed: 12 years ago10 years ago
Resolution: --- → WONTFIX
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.