Looks like you loose session when you close Firefox having a source window opened

RESOLVED DUPLICATE of bug 354894

Status

()

RESOLVED DUPLICATE of bug 354894
10 years ago
10 years ago

People

(Reporter: ramacciotti.alberto, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

Looks like you loose session when you close Firefox having a source window opened: a view-source-window open, a browser with many tabs open, close the browser then close view-source window, restart firefox: session doesn't starts; a new empty firefox session will starts,instead.

Reproducible: Always

Comment 1

10 years ago
Have you set Firefox to "Always show [your] windows and tabs from last time"? If not, this is a DUPE of bug 417675, otherwise this could be a DUPE of bug 354894.
Whiteboard: DUPEME
(Reporter)

Comment 2

10 years ago
my setup is "Always show [your] windows and tabs from last time"

Comment 3

10 years ago
Is the session correctly restored when you don't have a view-source window open? If not, this might rather be bug 398817 (clearing private data clears your session).

Else you'll have to make sure that Firefox has indeed quit after closing the view-source window in your original Steps to Reproduce (i.e. it doesn't show up in the Task Manager anymore). Note that only the very last closed browser window will be restored.
(Reporter)

Comment 4

10 years ago
The session is correctly restored if no view-source-window open.
I didn't check the task manager item,indeed.
(Reporter)

Comment 5

10 years ago
So:
1.Many tabs opened.
2.View source on a window.
3.task manager: firefox isn't closed.
4.close view source window.
5.task manager: firefox is closed now.
6.Launch firefox: session starts correctly from point 1.
7.Close all.
8.Launch firefox with many tabs opened.
9.view source on a window.
10.task manager: firefox isn't closed.
11.Launch firefox with view-source-window still open: no session is start up: blank new window, session lost.

Comment 6

10 years ago
Thanks for the detailed steps to reproduce. This is indeed bug 354894.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 354894
(Reporter)

Comment 7

10 years ago
Glad it could be helpfull,but reading duplicate of bug 354894 maybe could means that I didn't check well into the database.

Regards.
You need to log in before you can comment on or make changes to this bug.