CSS import no longer working for files other than .css

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Mark, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; .NET CLR 1.1.4322; InfoPath.1; Tablet PC 2.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

version 1 and version 2 of firefox allow this:
<style type="text/css">@import url(styles.css);</style>
<style type="text/css">@import url(stylesscript.aspx);</style>

however version 3 doesnt no longer allow 
<style type="text/css">@import url(stylesscript.aspx);</style>
doesnt allow displaying of styles from files other than .css

All other browsers, opera, safari, IE, chrome work using both methods. What has changed between version 2 and 3? This is logical usage as the stylesheet may change dynamically depending on time of day which is the best example of usage i can provide.

Reproducible: Always



Expected Results:  
should pull in style sheet which is printed by the aspx or other scripting.
Are you sure you are serving the aspx file with a mime type of text/css?
(Reporter)

Comment 2

9 years ago
text/css is used.

I have set up an example here:

http://stores.shop.ebay.co.uk/Shoes-for-Ladies__W0QQ_armrsZ1

Note that in IE the background is red, and in FF the style is ignored.
Tools/Error Console:
Error: The stylesheet http://ebaykit02.esp-digital.com/ebayapps/ebaycontrollers/controller-01.aspx was not loaded because its MIME type, "text/html", is not "text/css".
Source File: http://stores.shop.ebay.co.uk/Shoes-for-Ladies__W0QQ_armrsZ1
Line: 0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

9 years ago
I've found the bug. The server for some reason was ignoring the mime type specified. Not sure why, but i've defined it both in IIS and asp.net page now to override it. 

Thanks for your support.
Resolution: INVALID → FIXED
fixed means that there is something fixed in the mozilla source but that's not the case, it's invalid
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.