groupbox XUL element does not respond correctly to CSS property -moz-appearance

UNCONFIRMED
Unassigned

Status

()

Core
XUL
--
minor
UNCONFIRMED
9 years ago
9 years ago

People

(Reporter: Ned, Unassigned)

Tracking

({css2})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.12 KB, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6

When attempting to use -moz-appearance (specifically, -moz-appearance: none) on a groupbox element, there is no difference in appearance.

Setting -moz-appearance to other values has strange results as well; setting it to groupbox causes two groupboxen (sic) to be drawn as though they where stacked.

I tested this with and without a caption element, and with and without other children such as labels and buttons, all produced the same results.

Reproducible: Always

Steps to Reproduce:
1. Create XUL groupbox
2. Use CSS or style= attribute to add property "-moz-appearance: none"
Actual Results:  
groupbox appears unchanged -OR- in the case when a -moz-appearance other than "none" is specified, can appear incorrectly (see attachment)

Expected Results:  
groupbox appears as specified with child elements visible and stacked on top

Using the default Mac theme; no CSS other than chrome://global/skin/ and a style attribute on the groupbox was applied

Also tested on Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

This problem may not be Macintosh specific, however I am unable to verify.
(Reporter)

Comment 1

9 years ago
Created attachment 361248 [details]
Testcase for XUL groupbox -moz-appearance bug
(Reporter)

Updated

9 years ago
Keywords: css2

Updated

9 years ago
Component: General → XUL
Product: Firefox → Core
QA Contact: general → xptoolkit.widgets

Comment 2

9 years ago
(In reply to comment #0)
> Steps to Reproduce:
> 1. Create XUL groupbox
> 2. Use CSS or style= attribute to add property "-moz-appearance: none"
> Actual Results:  
> groupbox appears unchanged -OR- in the case when a -moz-appearance other than
> "none" is specified, can appear incorrectly (see attachment)

'none' is the default value for '-moz-appearance' for groupboxes on Mac, so you shouldn't see any difference. The element with -moz-appearance: groupbox is actually a child box.

Please reopen if you think there is an actual bug here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

9 years ago
I've looked into this further, and the workaround is to style descendant objects having class .groupbox-body with the -moz-appearance property.

This behavior is different from other scrollbox-type elements, such as richlistbox, which accept the property directly.

(In reply to comment #2)
> 'none' is the default value for '-moz-appearance' for groupboxes on Mac, so you
> shouldn't see any difference. 

Another question here however, is this behavior different from other platforms? If so, it seems this could break layouts, as the mechanism to achieve a custom-styled groupbox is different. In such a case, it may be better to classify Importance as "trivial" if this warrants a bug.

I'd only be willing to push for keeping this open if it isn't consistent across platforms.

If it's just a matter of knowing that the groupbox behaves differently from similar box-type elements, I'd just want to be sure it is documented somewhere (I wasn't able to find it), but that certainly doesn't warrant a bug.

> Please reopen if you think there is an actual bug here.

Based on the information I have added, I decided to open this again, apologies if this is not the appropriate or necessary action (I'm new here, just trying to do the right thing)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

9 years ago
The -moz-appearance property is by definition going to be platform specific, as is the specific elements and ways in which it applies. This is true of many elements, not just groupboxes.  

But I wonder what you're trying to accomplish. If you don't want an element that looks like a groupbox, why are you even using one?
You need to log in before you can comment on or make changes to this bug.