flash version is not recognized correctly

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Marc Auslander, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-1], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090209 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090209 Shiretoko/3.1b3pre

Several sites complain that flash is back level even though its not.  I've verified with about flash that the correct version is running.

In this page, if you attempt to select full screen, you will see a complaint about flash version.

Reproducible: Always

Steps to Reproduce:
see details

Actual Results:  
complaint about flash version

Expected Results:  
flash operation
Please type about:plugins as URL in Firefox and verify that flash10 appears there.
After that run Firefox in the Firefox safemode and try the page again.
- http://support.mozilla.com/en-US/kb/Safe+Mode

This works fine for me with flash 10 r12 with Seamonkey 1.9.1 branch on vista
(Reporter)

Comment 2

9 years ago
Shockwave Flash

    File name: C:\WINDOWS\system32\Macromed\Flash\NPSWF32.dll
    Shockwave Flash 10.0 r12

MIME Type 	Description 	Suffixes 	Enabled
application/x-shockwave-flash 	Adobe Flash movie 	swf 	Yes
application/futuresplash 	FutureSplash movie 	spl 	Yes

the dll exists and is 10.0.12.26 described as 10.0 r12

I see the same result in safemode.

Remember, flash works but a few sites get the wrong version info.

Running beta 2 does not show this problem, only shiretoko, even though they use the same profiles etc.

I actually removed beta2 and installed shiretoko in the mozilla firefox directory to eliminate any path name issues, and it still fails.
(Reporter)

Comment 3

9 years ago
I misspoke.  After reinstalling Beta 2, it also fails on the cbs web site.

I have run through that adobe procedure to make sure permissions are correct since they mention misidentifying version as a possible issue.
Can you please try a new, additional test Profile ?
http://support.mozilla.com/en-US/kb/Managing+profiles
(Reporter)

Comment 5

9 years ago
A new profile behaves the same way, as does safe mode.

The url posted fails, other's on the cbs site (such as CSI) work.

My vanguard account fails with shiretoko, works with beta2.

the cbs link posted fails with both.

sigh.
(Reporter)

Comment 6

9 years ago
the cbs.com problem also occurs with 3.0.6 on my machine, and on our other machine which has never has any beta's on it.

Comment 7

9 years ago
This is now the end of August and the problem still exists. A video that plays just fine embedded in a vendors page fails totally on YouTube's own site. URLs are given below:

Woodcraft.com: http://www.woodcraft.com/Family/2005894/2005894.aspx?tab=videos#videos&refcode=09IN05NL

YouTube.com: http://www.youtube.com/watch?v=YSw9LIjuUSQ

This is with FF 3.5.2 and Adobe Flash 10+
both URLs from comment #7 and the URl from comment#0 are wfm with SM trunk, FF3.5.2 on win32 and flash 10.0 r32

>fails totally on YouTube's own site
If it fails to play and you get no error message about the flash version you are posting in the wrong bug report.

Comment 9

9 years ago
(In reply to comment #8)
> both URLs from comment #7 and the URl from comment#0 are wfm with SM trunk,
> FF3.5.2 on win32 and flash 10.0 r32
> 
> >fails totally on YouTube's own site
> If it fails to play and you get no error message about the flash version you
> are posting in the wrong bug report.

YouTube message is: Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player. Get the latest Flash player. 

This is total nonsense.
Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Also, please consider using the most recent Firefox 4 beta build, your bug may be resolved there.
Whiteboard: [CLOSEME 2011-1-1]
(Reporter)

Comment 11

8 years ago
I haven't seen this in quite a while.  The original failing link no longer exists, but similar links work with 4.0b8pre.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.