Option+backspace and option+del do not work correctly

RESOLVED DUPLICATE of bug 462188

Status

RESOLVED DUPLICATE of bug 462188
10 years ago
2 years ago

People

(Reporter: redjen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20081204 Thunderbird/3.0b1

On Mac OS X you should be able to delete entire words by pressing option+backspace or option+delete (fn+option+delete on laptops). This does not work when composing or replying to messages.

Reproducible: Always

Steps to Reproduce:
1. Open a new message.
2. In the message body, type a few words.
3. Place your cursor at the end of a word. Press option+backspace.
4. Place your cursor at the beginning of a word. Press option+delete (fn+option+delete on a laptop).

Repeat steps 3 and 4 in a different application if you wish to see hte correct behavior.
Actual Results:  
The word was not deleted.

Expected Results:  
In step 3, the word behind the cursor should have been deleted.

In step 4, the word in front of the cursor should have been deleted.
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 462188
(Reporter)

Comment 2

10 years ago
Sorry about this, I missed that bug in search. Can someone please close/delete this?
See Also: → bug 1293498
You need to log in before you can comment on or make changes to this bug.