Closed Bug 477701 Opened 14 years ago Closed 14 years ago

[RTL] Save button of Library search is cut-off

Categories

(Firefox :: Theme, defect)

3.5 Branch
x86
macOS
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 3.6a1

People

(Reporter: whimboo, Assigned: ehsan.akhgari)

Details

(Keywords: rtl, verified1.9.1)

Attachments

(2 files, 1 obsolete file)

Attached image Save button is cut-off
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090209 Shiretoko/3.1b3pre Ubiquity/0.1.5 ID:20090209020514

After doing a search within the library, the search bar appears right beyond the toolbar. As you can see in the screenshot the save button is cut-off on the left side. I can see that with the Hebrew locale. No idea if that applies to all RTL locales or only occurs for Hebrew.
Henrik: Does this happen with Force RTL as well?

Tomer: you're not doing anything fancy in he's intl.css which can have this effect on he only, right?

(In reply to comment #0)
> Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre)
> Gecko/20090209 Shiretoko/3.1b3pre Ubiquity/0.1.5 ID:20090209020514

BTW, is this build ID correct?  (It's en-US.)  Just trying to see if it happens on trunk or 1.9.1.
You see the en-US locale string here because I've tested it with your add-on. Now I also run a test with the latest fa build on trunk and it still shows this problem.
Summary: Save button of Library search is cut-off → [RTL] Save button of Library search is cut-off
(In reply to comment #1)
> Tomer: you're not doing anything fancy in he's intl.css which can have this
> effect on he only, right?
Not that I know of, but we should pay attention for keeping all the RTL locale styles in sync with others.
(In reply to comment #3)
> (In reply to comment #1)
> > Tomer: you're not doing anything fancy in he's intl.css which can have this
> > effect on he only, right?
> Not that I know of,

Never mind, Henrik already confirmed that this happens on fa as well.

> but we should pay attention for keeping all the RTL locale
> styles in sync with others.

Yes, definitely.  We should probably give this a look before the 3.1 release...
Attached patch Patch (v1) (obsolete) — Splinter Review
The problem was caused by setting the start padding of #saveSearch instead of its left padding.  This caused the left padding of the button in RTL mode to be 0 pixels, which didn't leave any room for the leftcap image.

I tested this patch to make sure it has the desired behavior on the Mac OS X theme in an RTL build.
Assignee: nobody → ehsan.akhgari
Status: NEW → ASSIGNED
Attachment #361835 - Flags: review?(dao)
round-button-leftcap.png is 8px wide, so that's probably what the padding should be. The 1px left padding on #saveSearch .button-text should be removed.
Attached patch Patch (v2)Splinter Review
Addressed comments.
Attachment #361835 - Attachment is obsolete: true
Attachment #362264 - Flags: review?(dao)
Attachment #361835 - Flags: review?(dao)
Attachment #362264 - Flags: review?(dao) → review+
http://hg.mozilla.org/mozilla-central/rev/d3661c8e1597
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.2a1
Comment on attachment 362264 [details] [diff] [review]
Patch (v2)

Requesting approval for this theme-only and low risk patch which fixes a display problem for RTL locales on Mac OS X.
Attachment #362264 - Flags: approval1.9.1?
Flags: in-litmus?
Attachment #362264 - Flags: approval1.9.1? → approval1.9.1+
Verified on trunk and 1.9.1 branch:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fa; rv:1.9.2a1pre) Gecko/20090221 Minefield/3.2a1pre ID:20090221020633

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090221 Shiretoko/3.1b3pre ID:20090221020541
Status: RESOLVED → VERIFIED
Flags: in-litmus? → in-litmus-
Dão, any particular reason why you cleared in-litmus here?
Flags: in-litmus- → in-litmus?
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.