[W-1.1.*] View Collection Scaffolding

VERIFIED FIXED in BW-M1

Status

addons.mozilla.org Graveyard
Collections
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: fligtar, Assigned: rdoherty)

Tracking

unspecified
BW-M1

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Scaffolding: The View Collection scaffolding should display the collection name, names of all add-ons in the collection, and have a link to subscribe to the collection.
(Assignee)

Comment 1

9 years ago
Created attachment 361812 [details] [diff] [review]
Patch for sanity checking
Attachment #361812 - Flags: review?(lorchard)
Comment on attachment 361812 [details] [diff] [review]
Patch for sanity checking

Hmm... I can't seem to apply this patch.  It seems to expect that a file exists at site/app/views/collections/view.thtml

But, I don't see it in the HEAD revision of this branch:

https://svn.mozilla.org/addons/branches/bandwagon/site/app/views/collections/

Something seems kind of screwy :/
Attachment #361812 - Flags: review?(lorchard) → review-
For what it's worth, I was able to apply the parts of the patch for the model, which look fine and will actually help me get further with the API work.  The controller stuff looks okay too.

Seems like the issue is with the views, and probably just that one view.thtml
(Assignee)

Comment 4

9 years ago
I did rename display.thtml to view.thtml, that's probably the problem. Not sure how to fix that in the patch though...
(Assignee)

Comment 5

9 years ago
(In reply to comment #4)
> I did rename display.thtml to view.thtml, that's probably the problem. Not sure
> how to fix that in the patch though...

That was a `svn mv ` command.
(Assignee)

Comment 6

9 years ago
I've committed the patch in r22193 since Les ok'd most of the code and it will allow him to review it easily.

Les, if there's changes needed, let me know.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Looks fine to me after an svn up!
Verified FIXED (scope of scaffolding *only*) on https://preview.addons.mozilla.org/en-US/firefox/collections/view/787694ee-692f-102c-9a23-001e0bd9232c.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.