Using N for next unread message does not shift focus correctly in folder pane

RESOLVED DUPLICATE of bug 470416

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 470416
9 years ago
9 years ago

People

(Reporter: Bill Burns, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Opera/10.00 (Windows NT 5.1; U; en) Presto/2.2.0
Build Identifier: Thunderbird 3 Beta 1 and all Shredder nightlys

In TB2, when using N to read new messages across multiple folders, the focus in the folder pane automatically shifts when the next folder is accessed, and if the list of folders is longer than the screen, the folder pane scrolls to show the new folder.

TB3 does not do this.  The next folder name is highlighted, but the focus is left off-screen and the folder pane must be scrolled manually to see it. This also happens on all versions of Shredder since I started testing a few weeks ago, so it's functionality from TB2 that has been lost.

Reproducible: Always

Steps to Reproduce:
1. Set up enough folders so that some are off the bottom of the screen.
2. Add new messages to multiple folders, including the off-screen ones.
3. Use N to read messages in sequence.
Actual Results:  
Folder name focus shifts to off-screen folders, folder pane does not scroll.

Expected Results:  
Folder pane should have scrolled to reveal the currently active folder.

Comment 1

9 years ago
Actually, focus does not shift to the "next folder" that you advance to at all, if you use "open message in a standalone window"

If you then close the standalone window, you have absolutely no clue what message was last read.

Confirming, most likely a regression from bug 414038
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

9 years ago
Tested with 3.0b1pre ID:20080920112042
Scrolling in the folderpane seems to work fine when using "N" in the preview pane.

Using "N" in the standalone window does not even open the newsgroup folder advanced to, either pre bug 414038 or after (probably should but thats another bug
Blocks: 414038
Keywords: regression

Comment 3

9 years ago
Seems like a dupe of bug 470416.
Yep.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 470416
No longer blocks: 510646
No longer blocks: 414038
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.