Long message subject (or other header) widens 3 pane

VERIFIED DUPLICATE of bug 91662

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED DUPLICATE of bug 91662
18 years ago
13 years ago

People

(Reporter: BenB, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-][cut 8/29])

(Reporter)

Description

18 years ago
Reproduce:
1. Set your main Mailnews window (3 pane) to "normal" size
2. Open a msg with a long newsgroup header, e.g.
<news://news.mozilla.org/398C2D7A.FD9DE98@uumail.de>

Actual result:
- The newsgroups are not wrapped.
- The main window keeps the same size, but the content, in particular the msg
pane and with it the thread pane and the toolbars, are widened. As a result, the
right columns of the thread pane, the throbber and other UI is invisible.

Expected result:
- The newsgroups are wrapped
- The main window and all of the panes and toolbars keep their size.

Additional Information:
I think, the problem is that the sizes of the msg and thread pane are not
calculated correctly. There should be some manner in XUL to specify their sizes
dependant of the size of the main window, *not* their content (as seems to be
the case now).

Just as precaution: The problem is *not* that all newsgroups are shown. All
newsgroups *have* to be shown. And as they are currently displayed in an <html>
widget, they should wrap, if the problem described above is solved.
(Reporter)

Updated

18 years ago
Keywords: correctness, nsbeta3

Comment 1

18 years ago
can you attach a message which hasn't expired? Is this similar to 46411?
(Reporter)

Comment 2

18 years ago
You can easily recreate a new one by posting a msg to 10 or so newsgroups.

It is similar to bug 40036. I don't think, it is a dup, though, because I think,
we should forcefully constrain the size of the panes. A bug like 40036 might
appear again. Not sure, if this is still nsbeta3, though.
(Reporter)

Comment 3

18 years ago
The newsgroup problem is fixed with the other bug.

This propably still happens, if the subject is long and does not contain
whitespace.

Comment 4

18 years ago
This also sounds like bug 46411
QA Contact: lchiang → laurel

Comment 5

18 years ago
mail triage marking [nsbeta3+]

reassigning to mscott.
Assignee: putterman → mscott
Whiteboard: [nsbeta3+]
(Reporter)

Updated

18 years ago
Summary: Long newsgroups header widens 3 pane → Long header widens 3 pane
(Reporter)

Comment 6

18 years ago
Forgot to adjust summary.
(Reporter)

Comment 7

18 years ago
Also appears in the View All Headers mode, because the "Recieved" header is so
long that it doesn't fit in the msg pane. Interestingly, it doesn't wrap,
although it contains spaces. Is that another bug?

Comment 8

18 years ago
(just correcting fields to coincide with + status)
Keywords: mail2
Target Milestone: --- → M18
(Assignee)

Comment 9

18 years ago
When I try to display a message that just has a long subject field without any
spaces we can wrap, we just truncate the data at the end of the line. the 3pane
isn't actually made wider. I think that's reasonable enough behavior for now.

if the 3 pane was actually jumping and getting made wider than we still have a
problem worthy of beta3.
(Reporter)

Comment 10

18 years ago
> if the 3 pane was actually jumping and getting made wider than we still have a
> problem worthy of beta3.

The 3 pane never jumped around, and the size of the top-level window was always
the same. But the msg pane, and it the thread pane, were widened. Did you still
see the throbber in the upper-left corner?

Comment 11

18 years ago
second pass: - per mail triage
Whiteboard: [nsbeta3+] → [nsbeta3-][cut 8/29]

Comment 12

18 years ago
sorry for the extra email. Removing mail2 keyword.
Keywords: mail2

Updated

17 years ago
Target Milestone: M18 → ---

Comment 13

17 years ago
Related to 51616

Comment 14

17 years ago
This also looks related to bug 91662 (a dup?)
(Reporter)

Comment 15

17 years ago
*** Bug 91662 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Summary: Long header widens 3 pane → Long message subject (or other header) widens 3 pane

Comment 16

17 years ago
Fixed in bug 51616?

Comment 17

17 years ago
No, long to: and cc: addresses still cause this problem, and it's especially bad
when the message has file attachments too. See bug 91662 for the full story.

Btw how come all the cc:'s from 91662 didn't get copied back to this bug?

Comment 18

16 years ago
*** Bug 108884 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
I'm reversing the dup here since bug 91662 has test cases and analysis
and is more useful.

*** This bug has been marked as a duplicate of 91662 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 20

16 years ago
marking verified since laurel verified the earlier dup of 91662 against this
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.