No way to view PDF in browser window (nightly build)

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
9 years ago
8 years ago

People

(Reporter: Timothy Miller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090210 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090210 Shiretoko/3.1b3pre

Since 3.1b3pre, there's no way to view PDFs in a window on a Mac.  The QuartzPDF extension is marked as incompatible, Adobe's plugin simply doesn't appear in the list, and that Nitro thing that converts to HTML just doesn't work (produces errors).

I'm rather fond of viewing PDFs in browser windows.  Any plans to fix this?

Thanks.

Reproducible: Always
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 2

8 years ago
This is still a problem.  There is no built-in PDF support, and there is no facility to automatically find the facility built into the system (on a Mac).

There is a plugin for this, but it's not very good.  The plugin uses PDFKit, but it burns CPU when idle, which is odd, since Safari also uses PDFKit but uses zero CPU when idly viewing a PDF.
(Reporter)

Comment 3

8 years ago
Oh, and the plugin is always really really far behind the latest version.

Updated

8 years ago
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Whiteboard: [CLOSEME 2010-11-01]

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.