Shiretoko update window is incorrect and poor UX

RESOLVED DUPLICATE of bug 477776

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 477776
9 years ago
9 years ago

People

(Reporter: cmtalbert, Unassigned)

Tracking

1.9.1 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-03-21)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 361602 [details]
Picture of the Update Window

Check out the attached screen shot.  This is the update notice I got on a nightly update for Shiretoko (from the build: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090206 Shiretoko/3.1b3pre).

There are several things wrong here:
1. We shouldn't get the Major Update window unless we're actually doing a major update.  (AFAIK)
2. Next, the update mar should ALWAYS contain information for the inner window.  We control that content, and there is no excuse for us to not provide that URL. If we're not going to provide that information, then I'd argue that we shouldn't have the inner window at all.
3. If we are showing this error message in the case of some failure (which would be ok) we should linkify the "Shiretoko Homepage" to the Shiretoko Homepage so that the user doesn't have to guess what we're talking about and can go directly to it.

This is pretty poor UX, so I nom for blocking.
Flags: blocking1.9.1?
We're testing major update right now (bug 470881) so that dialog is expected. I'm not sure the missing content, could you attach <app_dir>/updates.xml here ? It might just be fallout from another update glitch today, see bug 477776, as it works fine for me at the moment.

Removing nom, because this I don't believe this is the apps fault.
Flags: blocking1.9.1?
1. is expected in that we are testing major updates on the nightly channel... have been for a while now and will go back to minor after the version bump.
2. needs more investigation as to why the content wasn't displayed... chances are it was either a network or server error.
3. is bug 349600.

Clint, can you check if it is working now that bug 477776 has been fixed and if it works for you please dupe over to bug 477776. Thanks
Clint, could you check if it is working now that bug 477776 has been fixed and if it works for you please dupe over to bug 477776. Thanks
Whiteboard: closeme 2009-03-21
Since no response to comment #3 I am going to assume that bug 477776 fixed this... if it hasn't (while keeping in mind comment #2) then please reopen.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 477776
You need to log in before you can comment on or make changes to this bug.