Closed Bug 477927 Opened 13 years ago Closed 13 years ago

6 TUnit test_browser_places/unit/* leak 1,012 bytes now

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 3.6a1

People

(Reporter: sgautherie, Assigned: mak)

References

Details

(Keywords: memory-leak, regression, verified1.9.1)

Attachments

(2 files)

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090117 Minefield/3.2a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/184eadf4e185 + bug 446300 patch)

No leak.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090210 Minefield/3.2a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/561dc7d5c746)

Affected tests:
test_384370.js
test_421483.js
test_457441-import-export-corrupt-bookmarks-html.js
test_bookmarks_html.js
test_browserGlue_prefs.js
test_browserGlue_shutdown.js
Flags: blocking-firefox3.1?
that's probably bug 474582
Blocks: 474582
(In reply to comment #0)

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090127 Minefield/3.2a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/13e95c7ff78b + bug 446300 patch)

No leak.

Regression timeframe:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2009-01-27+09%3A28%3A07&enddate=2009-02-10+14%3A06%3A15


(In reply to comment #1)
> that's probably bug 474582

At least, test_browserGlue_prefs.js and test_browserGlue_shutdown.js were added by that bug.
Marco: any idea what's causing the leak? 1k doesn't sound like a lot, especially if it's only when we actually import bookmarks (which only happens once) so I don't think this should block.

If it turns out that it's >1k and happening more frequently than on first-run/bookmark only, please renominate.
Flags: blocking-firefox3.1? → blocking-firefox3.1-
i think it should happen only with tests environment, but i still have to deeper look at it since our initialization is changed quite a bit recently.
Flags: wanted-firefox3.1?
Attached patch patchSplinter Review
we are laking the idle observer in browserGlue

looks like when we exit from the test init-complete has not yet completed, and we end up removing the idle observer and then adding it back when init-complete fires. I would have expected it to finish before tail is called, but this could be due to how xpcshell tests work. Shawn any idea upon that?

running the event loop before simulating quit-application solves the leak (allow to execute init-complete before we quit)... also browserGlue-prefs simulates the init many times, we need to simulate quit-application same number of times to clean up added idle observers.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #362617 - Flags: review?(sdwilsh)
tail files are sadly called right after the main test file is loaded, but before run_test is called
Attachment #362617 - Flags: review?(sdwilsh) → review+
Comment on attachment 362617 [details] [diff] [review]
patch

>+// Run the event loop to be more like the browser, which normally runs the
>+// event loop long before code like this would run.
>+// Not doing so could cause us to close the connection between all tasks have
>+// been completed, and that would crash badly.
s/between/before/ I think

r=sdwilsh
http://hg.mozilla.org/mozilla-central/rev/ddb3fe51d231

Serge please verify this on trunk, then i'll push to branch
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090219 Minefield/3.2a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/ddb3fe51d231)

V.Fixed
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
Target Milestone: --- → Firefox 3.2a1
Blocks: 485648
Flags: wanted-firefox3.5?
No longer blocks: 485648
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.