Unnecessary scrollbars appearing when right-clicking link

RESOLVED DUPLICATE of bug 286368

Status

()

RESOLVED DUPLICATE of bug 286368
10 years ago
10 years ago

People

(Reporter: andreasjunghw, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090211 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090211 Shiretoko/3.1b3pre

When you set display:block on a link and include this link in a div with overflow:auto, unnecessary scrollbars appear when you right click on that link.
(I will attach a testcase)

Reproducible: Always

Steps to Reproduce:
1.Open the testcase
2.Click on either of the links
3.
Actual Results:  
Scrollbars appear.
On the first link this even prevents the right click menu from opening.

Expected Results:  
No scrollbars appear, right click menu is displayed.
(Reporter)

Comment 1

10 years ago
Created attachment 361820 [details]
testcase
(Reporter)

Comment 2

10 years ago
Created attachment 361822 [details]
screenshot of the appearing scrollbars
I see this in all Firefox versions from 1.5, but not in Firefox 1.
Version: unspecified → Trunk

Comment 4

10 years ago
This is not limited to right clicking. Just focussing the link (e.g. tab to that link) is enough. The scrollbar is caused by the outline on the focussed link.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 286368
You need to log in before you can comment on or make changes to this bug.