Web page title is truncated when sent to a printer

RESOLVED DUPLICATE of bug 531606

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 531606
9 years ago
7 years ago

People

(Reporter: morlamweb, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

If you print a web page with a long title, like the Yahoo Mail login page, then the page title will be truncated in the output.  The best way to repro is to print to a virtual PDF printer like PDF Creator; the page title will be the Document Title in PDF Creator.  The whole title should be printed when you print a web page.

Reproducible: Always

Steps to Reproduce:
1. Load a webpage that has a long title OR load a local HTML file with a long filename/path.
2. Click File > Print.
3. Select a PDF virtual printer and click OK.  
Actual Results:  
Document Title: Yahoo! Mail: The best web-b...

Expected Results:  
Document Title: Yahoo! Mail: The best web-based email!

Comment 1

9 years ago
I just want to remind developers that this bug has not been present in Firefox 2.x branch.
(Reporter)

Comment 2

9 years ago
For reference, here's what the competition can do:
(I'm printing here to doPDFv6, PDFCreator isn't working today for me, and it replaces the ":" character with "_" because the colon is a reserved character.)

Google Chrome 1.0: Yahoo! Mail_ The best web-based email!
Opera 9.63: Yahoo! Mail_ The best web-based email!
Safari 3.2.1: Yahoo! Mail_ The best web-based email!
IE 6: login.yahoo.com_config_login_verify2__.src=ym
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 4

8 years ago
Tried again with Firefox 3.6.10, and the document title is still cut off.
Whiteboard: [CLOSEME 2010-11-01]
Version: unspecified → 3.6 Branch

Comment 5

8 years ago
I confirmed this bug also occurs with PDF995 PDF printer on Firefox 3.6.10 for Windows.

Duplicate bug report is here:
https://bugzilla.mozilla.org/show_bug.cgi?id=505010

Comment 6

7 years ago
There's another duplicate bug which has already been fixed: Bug 531606
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 531606
You need to log in before you can comment on or make changes to this bug.