Mac Classic Skin: Mail And News New Account Wizard has several problems

VERIFIED FIXED in mozilla0.9

Status

P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: lordpixel, Assigned: andreww)

Tracking

({classic})

Trunk
mozilla0.9
PowerPC
All
classic

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Build 2000080410

Try creating a new mail/news account while using the Mac classic skin:

This wizard needs some work:

It has the symptoms of bug 46192 - the panel headings are white
The icon in the panel headings is being clipped.
The buttons are in the wrong font.

Its just plain ugly. The layout look amatuerish.

Comment 1

19 years ago
setting bug status to New.  I also noticed (could be filed seperately I guess,
but...) that the buttons in the News Subscribe dialog are partially cut off when
using the classic skin (and what hapened to the stripes?)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

19 years ago
>that the buttons in the News Subscribe dialog are partially cut off when
>using the classic skin (and what hapened to the stripes?)

bug 47819

Comment 3

19 years ago
nominate for nsbeta3 for mail usage.
Keywords: classic, mailtrack, nsbeta3

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 4

19 years ago
Stripes are only being used in windows classic, not mac classic.
(Reporter)

Comment 5

19 years ago
Actually, the stripes are gone from windows classic too, and the marble effect 
is back. 

I think Asa is probably talking about the stripes in the main toolbar anyway. 
There was a long thread about this in either the ui or the xpfe newsgroups last 
week. I think Ben is going to try to bring them back on the toolbar.

Comment 6

19 years ago
Oh, those lines (which are copied from IE 5 for Mac and Mac OS X Aqua) have been 
removed becasue we've decided to minimize the visual design changes for the 
Classic skin.  Someone can very easily make an IE 5 skin with these lines, but 
the main priority for the classic skin is not to innovate but to copy 4.x's look 
as closely as technically possible. 

Comment 7

19 years ago
Updating QA Contact to pmac@netscape.com
QA Contact: paw → pmac

Comment 8

18 years ago
Can we reassign this to Ben as per skins triage meeting?  Changing to P4.

Updated

18 years ago
Keywords: mailtrack

Comment 9

18 years ago
Marking all P3 bugs nsbeta3-
Whiteboard: nsbeta3-
(Assignee)

Comment 10

18 years ago
Reassigning all Nikhil's bugs to me as he is no longer here. 
Assignee: nbhatla → andreww
Status: ASSIGNED → NEW
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 11

18 years ago
Someone's been doing good work here, many of the problems have been fixed in the
last few builds, however:

i) The title at the top of the window is illegable - it seems to be printed
white on white. Suggest we use the Marble background used elsewhere in the Mac
classic skin. (see attached image)

ii) The previous and next buttons are odd (see bug 55779)

iii) The buttons are using the wrong font. Should be using the fat system font
(Chicago, Charcoal etc) for buttons like these...
(Reporter)

Comment 12

18 years ago
Created attachment 16494 [details]
Image shows missing marble pattern in New mail account wizard, and also correct pattern in preferences for a contrast.
(Assignee)

Updated

18 years ago
OS: All
Priority: P3 → P2

Comment 13

18 years ago
Themes Triage Team P3
Keywords: nsbeta3
Priority: P2 → P3
Whiteboard: nsbeta3-
(Assignee)

Comment 14

18 years ago
setting milestone
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 15

18 years ago
Created attachment 25205 [details] [diff] [review]
patch for classicbindings.xml and dialogoverlay.css

Comment 16

18 years ago
sr=hewitt

Comment 17

18 years ago
I generally prefer the url in quotes.  No big deal. r=blake
(Assignee)

Comment 18

18 years ago
fix checked in. All issues here are now either fixed or are addressed already in
other bugs... Marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 19

18 years ago
Marking verified on Mac (2001-02-21-04-Mtrunk)
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.