Downloaded files only retain first word, and errors have occurred with opening downloaded MSWord files even after correct extension is added.

VERIFIED INVALID

Status

--
minor
VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: dborkows, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.19) Gecko/20081212 Camino/1.6.6 (MultiLang) (like Firefox/2.0.0.19)
Build Identifier: Camino/1.6.6 (MultiLang) (like Firefox/2.0.0.19)

When downloading a file like "File Name", only the word "File" will be retained after download.  It then will be without an extension, and even after adding such an extension with MSWord '07 files, you can't open them by clicking on the icons, you need to go through the "open" command after opening word.

Reproducible: Always

Steps to Reproduce:
1.download a file
2.add extension to a word file
3.try opening downloaded file from finder/desktop
Actual Results:  
I just got a blank document.

Expected Results:  
It should have opened the word document.

It seems like it is two errors that are connected to one another, hence I am posting them together.

Comment 1

10 years ago
Servers are required by spec to enclose any filename with spaces in quotes in the response header. Servers failing to do this is without fail the cause of the behavior you are seeing, so this is a bug with the site you are downloading from, not Camino. You should report it to the administrator of that site.

(Some other browsers will use the full name even without quotes, but this is both a violation of the spec and a behavior that makes it impossible to correctly handle some cases from servers that follow the spec and correctly quote the name.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.