Closed Bug 478239 Opened 11 years ago Closed 11 years ago

Dragging images from Firefox or Minefield into a desktop folder icon causes the folder icon to relocate to the first open position on the right

Categories

(Core :: Widget: Cocoa, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 401380

People

(Reporter: notforyourmail, Assigned: jaas)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090212 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090212 Minefield/3.2a1pre

Summary:
Dragging an image into a folder on the desktop causes the folder to relocate to the first available position on the desktop.



Reproducible: Always

Steps to Reproduce:
Steps to Reproduce:

1) Create a new folder on the desktop.  Place it somewhere around the middle of the screen.

2) Ensure the finder is set to NOT autoarrange files

3) Start Firefox.  I've tested this on both 3.1 beta 2 and Minefield 3.2a1pre.  Minefield is the latest nightly testing build of Firefox.

4) Drag an image from the browser into the folder.  I've tested this using images from both nytimes.com and facebook.com with identical results.

5) The folder moves from its current position to the first open position on the right side of the screen.

Note that if the folder is open and you drag the image into a finder window instead of onto the folder icon, the folder does not relocate.

Actual Results:  
folder moves unexpectedly to first open spot on the right.

Expected Results:  
Folder stays put.
Note: I've tried the same experiment with Safari.  The folders do not move when I drag images onto them from Safari, so this looks like a Firefox specific bug.
What a bizarre little bug!

I've confirmed in FF 3 and 1.9.0-branch Camino.  It doesn't happen in
FF 2 or 1.8-branch Camino.

It happens on both OS X 10.5.6 and 10.4.11.

Here's the regression range:

firefox-2007-07-16-04-trunk
firefox-2007-07-17-04-trunk

This pretty clearly implicates the patch for bug 358093 ("support
promised file dragging in cocoa").
Assignee: nobody → joshmoz
Status: UNCONFIRMED → NEW
Component: General → Widget: Cocoa
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → cocoa
Blocks: 358903
No longer depends on: 358903
Blocks: 358093
No longer blocks: 358903
Isn't this bug 401380 ?
Yes, so it is.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401380
You need to log in before you can comment on or make changes to this bug.