Closed Bug 478349 Opened 12 years ago Closed 12 years ago

Open an email link with firefox to create a loop.

Categories

(Firefox :: File Handling, defect)

3.0 Branch
x86
Windows Vista
defect
Not set
trivial

Tracking

()

RESOLVED DUPLICATE of bug 167320

People

(Reporter: Franpa_999, Unassigned)

Details

(Keywords: access, mail-integration)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.6) Gecko/2009011913 Minefield/3.2a1pre;MEGAUPLOAD 1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.6) Gecko/2009011913 Minefield/3.2a1pre;MEGAUPLOAD 1.0

Hi, if you open an email link with firefox.exe then Firefox will end up stuck in a loop repeatedly opening new tabs over and over until you close Firefox.

Reproducible: Always

Steps to Reproduce:
1. Find an email link such as a MAILTO one.
2. open it and use Firefox.exe as your email client when asked what program to use to open the link. (I assume you don't have a default email client setup in firefox yet)
Actual Results:  
keeps generating a new tab in firefox, you MUST close firefox to stop it. It makes Firefox consume 150mb~ memory.

Expected Results:  
either 5 new tabs then a warning or just... have firefox report that it itself can't be used in that manner.
Severity: normal → trivial
Version: unspecified → 3.0 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 167320
You need to log in before you can comment on or make changes to this bug.