After "newfile" or "load" command, focus() not set on editor.

RESOLVED WONTFIX

Status

--
minor
RESOLVED WONTFIX
10 years ago
10 years ago

People

(Reporter: SmilingRob, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_6; en-us) AppleWebKit/530.1+ (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1
Build Identifier: 0.1

When you type the "newfile" or "load" commands the focus is still on the command line.  It would be nice to have it on the editor.

Reproducible: Always

Steps to Reproduce:
1. type "newfile test.html" in the command line
2. observe cursor still in command line, although new document is open

Actual Results:  
Cursor is still on the command line.

Expected Results:  
Cursor should be in the editor.

Comment 1

10 years ago
Robert,

Good point. We will have to think about this. As you say, in some ways normally people expect to stay in command lines. I have gotten used to jumping focus with Ctrl-J, so I would do:

newfile
ctrl-j

Will have to play with this.. maybe make it a setting?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

10 years ago
Created attachment 362194 [details] [diff] [review]
Removes focus from command, adds focus to editor.

The two lines are stolen from commandline.js
cl.commandline.onkeydown {
if (e.keyCode == Key.J && e.ctrlKey)
...
}
(Reporter)

Comment 3

10 years ago
How do other command line tools work?  I don't use them since I use TextMate, if emacs and vi focus on the editor, then maybe the default should do that too?  But if they don't please ignore this ;)  Thanks!  

After learning about the Ctrl+J thing, it does feel a little strange with the patch applied to have it auto focus.
OS: Mac OS X → All
This is a mass migration from Mozilla Labs :: Bespin to Bespin :: General.

This bug likely still needs to be triaged and categorized.
Component: Bespin → General
Product: Mozilla Labs → Bespin
QA Contact: bespin → general
Target Milestone: -- → ---

Comment 5

10 years ago
The command line has changed.....
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.