Non US/UK keyboard support is poor

RESOLVED FIXED in 0.6

Status

Skywriter
General
--
enhancement
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: jwalker, Unassigned)

Tracking

Dependency tree / graph

Details

Attachments

(1 attachment)

From watz on the mailing list:
For example, the "alt gr" key doesn't work, which makes it impossible to enter certain characters on a German keyboard (like curly braces). This makes editing code currently quite impossible :-) Also characters not present in an US layout don't work (German Umlaute, like äöü). Keys that work produce characters matching the layout however. It just looks like bespin alpha implements some own key<->character translation logic for the editor, that still needs internationlization support.

Updated

9 years ago
Duplicate of this bug: 478402

Updated

9 years ago
Duplicate of this bug: 478486

Comment 3

9 years ago
Created attachment 362490 [details] [diff] [review]
this is a patch to fix this bug

Maybe char codes range was limited with some purpose. If not i think 
following changes will work for most languages.

Comment 4

9 years ago
This will work for keys that tie in, but doesn't work for me on a US keyboard typing Option-N on the Mac for example. Still need to fix that. Eldar, many thanks for the patch.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
Either this was fixed or it wasn't. It's definitely not INCOMPLETE, so I'm reopening it.

It also seems like a lot of related bugs are hanging around that may or may not be duplicates or dependents of this bug or another bug.

Bugs to look at include:
bug 478402 - non Latin characters are not supported
bug 478486 - Bespin editor: Unable to add international text
bug 485797 - Option key does not work (for inserting symbols and accented characters)
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---

Updated

9 years ago
Blocks: 485823
Blocks: 485797
This is a mass migration from Mozilla Labs :: Bespin to Bespin :: General.

This bug likely still needs to be triaged and categorized.
Component: Bespin → General
Product: Mozilla Labs → Bespin
QA Contact: bespin → general
Target Milestone: 0.2 → 0.2.x

Updated

8 years ago
Target Milestone: 0.2.x → ---

Updated

8 years ago
Severity: critical → enhancement

Updated

8 years ago
Duplicate of this bug: 534518

Updated

8 years ago
Duplicate of this bug: 534529
Duplicate of this bug: 522853
I've created a text input mixin that will be used in the (MVC-)reworked view. It supports internationalized input via DOM Level 3 textInput/DOMNodeInserted/DOMCharacterDataModified events, with an invisible view.

Thanks to Julian Viereck for the general idea - this variation was chosen to avoid key events, to be compatible with IMEs and the like.

[needs-pull] Changeset 052ffd0bf15b @ http://bitbucket.org/pcwalton/bespinclient/
Whiteboard: needs-pull

Comment 11

8 years ago
The TextInput mixin looks like a good beginning. I've merged and pushed that 
change, but I'm not closing this bug yet since this still needs to be 
integrated into the editor.

Updated

8 years ago
Whiteboard: needs-pull

Comment 12

8 years ago
This was fixed in the 0.6 release.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.6
You need to log in before you can comment on or make changes to this bug.