FireFox 3.0.6 with plug-in 'Google Toolbar for Firefox' conflicts with TurnTool plug-in

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
8 years ago

People

(Reporter: per, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [caused by google toolbar], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

Hello!

I am the main developer of the realtime 3D plug-in for the web called TurnTool.
We have about 250.000 downloads of our plug-in each month.

Last week we upgrade to FireFox 3.0.6 and discovered that our TurnTool plug-in stopped working just after updating to FireFox 3.0.6. The only way to solve the problem was to disable the plug-in called 'Google Toolbar for FireFox'.

You need the TurnTool Viewer to reproduce the problem.
First install the TurnTool plug-in using this xpi. http://www.turntool.com/ViewerInstall.xpi

This page is only 23 lines long so it should be simple to see that is going on.

http://studio.turntool.com/FireFox3.0.6_Problem/TTV2_DHTML/

If the plug-in called 'Google Toolbar for Firefox' is disable then TurnTool 3D will be shown as expected. This is not the case if the 'Google Toolbar for Firefox' is enabled.

What makes to problem even weirder is that if the TurnTool Viewer is inserted into the HTML page using document.write then it works regardless of whether the Google Toolbar for Firefox is enabled.

Here is an example of this.

http://studio.turntool.com/FireFox3.0.6_Problem/TTV2_DocumentWrite/

I hope you can find a solution to this problem or tell me what changes are necessary in the TurnTool PlugIn.




Reproducible: Always

Steps to Reproduce:
1. First install the TurnTool plug-in using this xpi. http://www.turntool.com/ViewerInstall.xpi
2. Make sure that you have the Plugin called 'Google Toolbar for Firefox'
3. Open this very simple HTML page using the TurnTool plugin. http://studio.turntool.com/FireFox3.0.6_Problem/TTV2_DHTML/


Expected Results:  
Expected Results is to see the TurnTool Viewer working as it does for all previous versions of FireFox until 3.0.6.

We have supported FireFox since version 1.0 and we have always until now been able to resolve problems ourselves when new versions of FireFox were released.
(Reporter)

Updated

10 years ago
Keywords: embed
Whiteboard: FireFox 3.0.6 with plug-in 'Google Toolbar for Firefox' conflicts with TurnTool
Is there a google toolbar plugin or do you mean the google toolbar ADDON ?
Keywords: embed
(Reporter)

Comment 2

10 years ago
As far as I know there is only one 'Google Toolbar' so yes I mean ADDON.

It is the one you can install from http://toolbar.google.com
I asked because the google Toolbar could contain a additional plugin, don't expect that everyone knows each detail of every addon.

If the Addon breaks your plugin you have to report this the google Toolbar developers if it works without. I and our developers don't know what they are doing with their addon that contains binary components and not just JS/HTML/XUL.
(Reporter)

Comment 4

10 years ago
Thank you for your reply. Do you know know to reach the Google Toolbar developers?
Or could you forward this bug report to them?

I know this sounds strange but it was the updated from Firefox 3.0.5 to 3.0.6 that triggered a changed in behaviour of Google Toolbar which caused the TurnTool Viewer 2 plug-in to stop working.

We have another plug-in/extension under development called TurnTool Viewer 3.
This new plug-in actually works both with and without the Google Toolbar.
But only if you do not use the 'src' parameter in the <embed> tag.

Here are two almost identical HTML pages. The only difference is this ' src="" ' (8 letter in total)

Only the first of the two links work with Google Toolbar in FireFox 3.0.6.

http://studio.turntool.com/FireFox3.0.6_Problem/TTV3_DHTML/
http://studio.turntool.com/FireFox3.0.6_Problem/TTV3_DHTML_With_Src/

You need to install our plug-in to reproduce the problem
http://www.turntool.com/PluginInstall.xpi

Can anyone give me any insight into why Google Toolbar would crash plug-ins using the 'src' parameter in <embed> tags?

Any help anyone can give me on this will be greatly appreciated.
I can only explain the situation but that will not help (sorry).

An addon can do everything inside a browser, modifying the UI and the rendered content. For a valid bug the addon developer must explain what he is doing. Our developers can look at the issue if they know what the Addon is doing and can either confirm the bug on our side or mark the bug invalid because the addon is doing something wrong.
That things stops working with addons from one release to the next is not unusual if they use unfrozen (private) interfaces. 

The situation is more complicated in this case because the browser itself is not affected by the addon. You as third party got an issue with another third-party addon and Mozilla.org sits on the fence.

 I don't know how to contact google for the toolbar but you could try it here :
http://www.google.com/support/toolbar/bin/request.py?contact_type=contact_policy

Note: I'm only a bug triager and don't fix bugs

Updated

10 years ago
Whiteboard: FireFox 3.0.6 with plug-in 'Google Toolbar for Firefox' conflicts with TurnTool
Please report to Google if you still see this with the latest Google Toolbar version and firefox 3.6.3. Problems in the google toolbar can not be fixed by us.
Whiteboard: [caused by google toolbar]
Version: unspecified → 3.0 Branch

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

8 years ago
Yes I understand. We have found a solution to this problem.
Thank you.
You need to log in before you can comment on or make changes to this bug.